1993 Chevy S-10 Blazer Still won't run

Tiny
LADYBUG_IOWA
  • MEMBER
  • 1993 CHEVROLET BLAZER
I have a 1993 Chevy s10 Blazer 4x4 with about 125,000. This is a follwo up to a question posted last week. We have changed most of the electrical components on the blazer - the iginition module. The fuel pump relay and we have realized that our new fuel is only giving us 15 PSI of pressure and our engine requires 55-61 PSI of pressure, we are going to change the fuel pump, again, and I was wondering if you would have any suggestions what might need to be changed if the vehicle still does not start. It will currently turn over but will start and if we spray starting fluid on the intake it will take right off until that burns off. Suggestions welcomed. Thanks
Do you
have the same problem?
Yes
No
Monday, July 30th, 2007 AT 1:20 PM

2 Replies

Tiny
HIGHOUTPUTV6
  • MEMBER
I have the same make model year and its a 4x4 and I had the same problem but might not be as easy as mine was it could be more technical but I came to a conclusion that I had cracked fuel lines and replaced them and runs perfect again. Thats the only suggestion I have-good luck!
Was this
answer
helpful?
Yes
No
Friday, August 3rd, 2007 AT 2:37 PM
Tiny
RAYT333
  • MEMBER
Did they give you the correct fuel pump at the auto parts? The fuelpumps look the same but the pressure is very different.
Was this
answer
helpful?
Yes
No
Friday, November 2nd, 2007 AT 8:44 AM

Please login or register to post a reply.

Recommended Guides