Fuel pump

Tiny
SHOCKJOE5
  • MEMBER
  • CHEVROLET ASTRO
1992 Astro Van milage 211376 v-6 not sure of size. I got hit in the rear about 6 month ago an when I got hit it would not start afterwards. I droped the fuel tank and found that the wires that go to the pump had be jared apart, so I plugged it back in and the pump would come on about 5-10 sec. I put a new relay on and put it all back together an it still don't run. I can spray starter fluid in the carb an it will run for a little bit. Thanks for any help.
Do you
have the same problem?
Yes
No
Saturday, October 20th, 2007 AT 1:21 PM

3 Replies

Tiny
RASMATAZ
  • MEMBER
Check the fuel pressure with a gauge. The pump can come on but is it producing the correct pressure? If its getting the correct pressure. Now we have to find out why its not being delivered to the injector/s.

Crank the engine over while listening to the injector/s are they clicking? If not could be the computer's injector drivers or the power to it.

To accurately check you need a noid light.
Was this
answer
helpful?
Yes
No
Saturday, October 20th, 2007 AT 2:21 PM
Tiny
SHOCKJOE5
  • MEMBER
Well I fixed the pump. The wire clip on top of the houseing that the pump plags into is broke. I put the pump in a cup of gas an turned it on and it would babble so I turned the wire around and it started pumping. Now I got to fix the abs breaks.
Was this
answer
helpful?
Yes
No
Saturday, October 20th, 2007 AT 11:37 PM
Tiny
RASMATAZ
  • MEMBER
Its nice to hear you got the fuel system fixed, Now you have to worry about them brakes you can comeback again for further help.

Good Luck
Was this
answer
helpful?
Yes
No
Sunday, October 21st, 2007 AT 1:26 AM

Please login or register to post a reply.

Recommended Guides