2003 Chevy Astro climate control

Tiny
LOUIE666
  • MEMBER
  • 2003 CHEVROLET ASTRO
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 102,000 MILES
AC blows cold only through defrost.
No matter where I turn the climate control.
Is the switch itself bad? Or just something as simple as a vacuum line off?

Thanks

Updated 6/1/09
You guys know your stuff, I replaced all of the vacuum lines, AC works great and the air blows where its supposed to.

Thanks again
Ken
Do you
have the same problem?
Yes
No
Thursday, May 21st, 2009 AT 2:16 PM

2 Replies

Tiny
DOCFIXIT
  • EXPERT
Hi
Controls are vacuum so a leak would cause fault. Your system is in default mode all air out defrost. The control head needs to come out to get at master select switch. Do you hear any air hissing? Check around underdash see if hose off. Also check under hood on bulkhead on pass side vacuum line from engine goes through see if attached.
Let me know
Thanks for donate
Was this
answer
helpful?
Yes
No
Thursday, May 21st, 2009 AT 2:41 PM
Tiny
TECHMAN1
  • MEMBER
This is not complicated. There is a vacuum control line that runs from behind your air conditioner compressor to a plug behind your window washer reservoir. This tiny 4 millimeter black plastic line bakes and gets brittle and cracks or seperates.

It usually breaks just to the left of the air filter body.

I have actually spliced them back with a one inch piece of weedeater fuel line.

If you are a perfectionist, under the windshield washer and radiator overflow tanks, is a vacuum tank about the size of a softball and black plastic. You may have to pull the top half of the radiator shroud cover to get your hands in there, but you could replace all these vacuum lines.
Was this
answer
helpful?
Yes
No
Thursday, May 21st, 2009 AT 10:44 PM

Please login or register to post a reply.

Recommended Guides