C0035 left front wheel speed sensor circuit fault

Tiny
MARK FRIZZELL
  • MEMBER
  • 2007 GMC CANYON
  • 3.7L
  • 5 CYL
  • 4WD
  • AUTOMATIC
  • 180,000 MILES
I keep getting this code. I have replaced hub, speed sensor, rotor, rotor bracket. I do have continuity on wires from sensor to module. It was engaging ABS every time I would brake at a stop until I changed the rotor and bracket. I think it was rubbing but now I am still getting light and code?
Do you
have the same problem?
Yes
No
Friday, April 7th, 2017 AT 11:39 AM

8 Replies

Tiny
KEN
  • ADMIN
Hello, it sounds like you have a short in the controller. In particular the left front actuation solenoid.

Here is a guise to help you replace it.

https://www.2carpros.com/articles/how-to-replace-a-abs-controller

Please let us know what happens.

Best, Ken

Was this
answer
helpful?
Yes
No
Sunday, April 9th, 2017 AT 5:49 PM
Tiny
MARK FRIZZELL
  • MEMBER
We replaced complete abs unit, new hubs with sensors, rotors, pads. Code is c0035
Was this
answer
helpful?
Yes
No
Sunday, April 9th, 2017 AT 6:37 PM
Tiny
KEN
  • ADMIN
Must be missing something, Here is the wiring diagram for the circuit. Double check the connector to make sure one of the terminals has not pulled out of the connector.

https://www.2carpros.com/articles/how-to-check-wiring

I assume the light was on before changing the hub with sensor?

Was this
answer
helpful?
Yes
No
+2
Sunday, April 9th, 2017 AT 7:19 PM
Tiny
MARK FRIZZELL
  • MEMBER
Went back to drawing board, unplugged both front sensors, put DVM on each side checked ohm resistance first on right side I got 435 however on the right side I got no resistance
Was this
answer
helpful?
Yes
No
Monday, April 10th, 2017 AT 9:31 AM
Tiny
MARK FRIZZELL
  • MEMBER
Sorry I meant the other way round, no resistance on left side which is where we seem to have issues I should have resistance correct?
Was this
answer
helpful?
Yes
No
Monday, April 10th, 2017 AT 9:33 AM
Tiny
KEN
  • ADMIN
Yes you should. Try this test,

https://www.2carpros.com/articles/abs-wheel-speed-sensor-test

See if the sensor is working

Let me know, Ken
Was this
answer
helpful?
Yes
No
+1
Monday, April 10th, 2017 AT 10:28 AM
Tiny
MARK FRIZZELL
  • MEMBER
Hey Ken, bad new hub and sensor, that's what I get for buying Jap junk thx for your help
Was this
answer
helpful?
Yes
No
Monday, April 10th, 2017 AT 11:38 AM
Tiny
KEN
  • ADMIN
Glad you could get it fixed please use 2CarPros. Com anytime we are here to help

Best, Ken
Was this
answer
helpful?
Yes
No
+1
Monday, April 10th, 2017 AT 11:45 AM

Please login or register to post a reply.

Recommended Guides