Electric cooling fans not working

Tiny
WALT SARKOZY
  • 1995 BUICK ROADMASTER

Electrical problem V8 Two Wheel Drive Automatic 140000 miles

primary fan comes on with ac on. Secondary fan not coming on at all. Relays and fuses are good. Temperature switch replaced. Could the ecm be bad? THANKS!

Do you
have the same problem?
Yes
No
Friday, July 9th, 2010 AT 10:46 PM

4 Replies

Tiny
BLUELIGHTNIN6
  • EXPERT
  • 16,970 POSTS

The fan's motor is more likely to be bad then the computer, test the motor by supplying 12v direct power to it.

Was this
answer
helpful?
Yes
No
+1
Friday, July 9th, 2010 AT 10:52 PM
Tiny
WALT SARKOZY
  • MEMBER

Yes both motors work when connected to the 12 volts. Its strange that the the primary fan comes on only when the ac is on. The secondary fan is supposed to do that but the secondary fan is not coming on at all. Thanks!

Was this
answer
helpful?
Yes
No
+1
Saturday, July 10th, 2010 AT 5:51 PM
Tiny
CHARLES NOBLE
  • MEMBER

I hooked up a engine cooling fan switch to a pink ignition wire under the dash with the fan on when I turn the motor off it wants to keep running

Was this
answer
helpful?
Yes
No
Monday, July 17th, 2017 AT 4:00 PM
Tiny
2CARPROS KEN
  • ADMIN
  • 9,554 POSTS

Hello,

I would just connect the fans correctly to solve the problem. Here is some guides and a wiring diagram (below) that will help you get the job done.

https://www.2carpros.com/articles/how-to-check-a-car-fuse

and

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

and

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

Please let us know what you find.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Tuesday, July 18th, 2017 AT 10:32 AM

Please login or register to post a reply.

Recommended Guides