1994 Buick Century Need help

Tiny
NIKKI_74
  • MEMBER
  • 1994 BUICK CENTURY
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 123,000 MILES
Just bought a 1994 buick century, im have a problem with it stalling doesnt happen all the time and it only happens when I come to a stop if I let is set for about 10 min it will start back up and go till I come to another stop. Please help. Thank you for your time.
Do you
have the same problem?
Yes
No
Friday, October 22nd, 2010 AT 5:14 PM

7 Replies

Tiny
RASMATAZ
  • MEMBER
Next time it refuses to start don't wait for it to make up its mind-do below immediately to determine if its fuel or spark problem

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine atleast 3/16 away from ground-have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, Do you hear the fuel pump come On when you turn key on? If not check fuel pump fuse and fuel pump relay if so, check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs, coil's resistances, cap and rotor, distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it and keep testing
Was this
answer
helpful?
Yes
No
Friday, October 22nd, 2010 AT 5:50 PM
Tiny
NIKKI_74
  • MEMBER
It doesnt refuse to start I can turn it back over and it will start but when I put in gear it will satll out. While in throttle run fine when come to stop sign/ light shimmy shakes, makes loud noise and shuts off, after 10 min it will fire back up, and run good till next stop. Thank yo very much for you time.
Was this
answer
helpful?
Yes
No
Friday, October 22nd, 2010 AT 6:14 PM
Tiny
RASMATAZ
  • MEMBER
Try disconnecting the transmission converter clutch solenoid and see what happens
Was this
answer
helpful?
Yes
No
Friday, October 22nd, 2010 AT 7:41 PM
Tiny
NIKKI_74
  • MEMBER
Cant find where its located at, but would it have a transmisson clutch solanoid since its an automatic transmisson.
Was this
answer
helpful?
Yes
No
Saturday, October 23rd, 2010 AT 9:04 AM
Tiny
NIKKI_74
  • MEMBER
Ok found where it is, drove the car til it did the issue which was about 15 miles disconnected it an drove it for about 7 miles did not shimmy, shake, or stall, so that mean my solanoid is bad.
Was this
answer
helpful?
Yes
No
Saturday, October 23rd, 2010 AT 1:24 PM
Tiny
RASMATAZ
  • MEMBER
The TCC solenoid is contain within the transmission valve body find the pigtail for it-disregard it for the time being and do this clean out the idle air control valve and EGR valve and test the thorttle position and manifold absolute pressure sensors-Get a repair manual this problem can drag on-
Was this
answer
helpful?
Yes
No
Saturday, October 23rd, 2010 AT 1:25 PM
Tiny
NIKKI_74
  • MEMBER
Thank you very much for your help. The throttle sensor is brand new.
Was this
answer
helpful?
Yes
No
Saturday, October 23rd, 2010 AT 2:09 PM

Please login or register to post a reply.

Recommended Guides