Air condition blowing warm air

Tiny
JEEPLYFE
  • MEMBER
  • 2000 MERCEDES BENZ 430E
  • 4.3L
  • V8
  • 2WD
  • AUTOMATIC
  • 164,000 MILES
Air Condition was decently cooling, but I may have possibly (hypothetically) overcharged the A/C system with Freon, it now blows out warm air. Just recently after I noticed that the Cooling Fans were not turning on, I replaced the "aux fan" relay and the fans did turn on again. Now (a few days) after I just put a New relay in, the cooling fans are not working again. Is it a possible "open wire", or maybe the fans are going out, etc?
Do you
have the same problem?
Yes
No
Tuesday, September 14th, 2021 AT 4:40 PM

3 Replies

Tiny
ASEMASTER6371
  • EXPERT
Good evening,

The first thing I need is the Freon pressures for the high and low sides while the engine is running. I need those pressures to see if there is an issue with any of the components.

https://www.2carpros.com/articles/car-air-conditioner-not-working-or-is-weak

Since you added Freon without knowing it was low or not, I would start by recovering all the Freon, evacuating the system, and charging it to the proper amount. I attached a guide for you of the procedure below.

https://www.2carpros.com/articles/re-charge-an-air-conditioner-system

Let us start here and see if that takes care of the issue. The fans may not be coming on due to low Freon.

Once we get the Freon system working correctly we can continue if there are any other issues.

Roy

Was this
answer
helpful?
Yes
No
+1
Tuesday, September 14th, 2021 AT 4:51 PM
Tiny
JEEPLYFE
  • MEMBER
Alright, I will have to get a Mechanic to check it out, or actually purchase that Pressure kit myself. Will be in contact. Thanks
Was this
answer
helpful?
Yes
No
Wednesday, September 15th, 2021 AT 10:59 AM
Tiny
ASEMASTER6371
  • EXPERT
You are welcome.

Keep us updated so we can continue to help.

Roy
Was this
answer
helpful?
Yes
No
Wednesday, September 15th, 2021 AT 12:27 PM

Please login or register to post a reply.

Sponsored links