1995 Acura Integra Need desperate help.

Tiny
EMPYRECITIZEN
  • MEMBER
  • 1995 ACURA INTEGRA
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 150,000 MILES
I cut my antifreeze/heater hose by accident and it squirted out some of my coolant, I then had to drive it about 8 miles to the garage to put a new hose on and add coolant. Half way to the garage the car engine would shake whenever I would step on the gas, however it did not overheat on me. The new hose and coolant was added, the mechanic said I had lost 1/2 to 1 whole gallon of antifreeze my car holds 2 gallons. After having it fixed the car still shakes when I hit the gas and it has a hard to getting up to even 65 mph! My father said that I might have warped the head on my car because my Flowmaster cold air intake is letting in too much air but I told him that that couldn't be the problem because I've had the intake in for about 5 days now. Please help, any feedback would be greatly appreciated.
Do you
have the same problem?
Yes
No
Monday, August 25th, 2008 AT 5:07 PM

1 Reply

Tiny
MHPAUTOS
  • EXPERT
Hi there,

The first thing to do is have a scan done to check for any set fault codes, have the basic tune items checked and get the fuel system & ignition system checked as well, it would not hurt to get a head check done, this will check for exhaust gasses in the cooling system, but I feel that you may just have a tune problem, start here.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Monday, August 25th, 2008 AT 6:06 PM

Please login or register to post a reply.

Recommended Guides