Will not shift into second gear

Tiny
CHRISFWLR88
  • MEMBER
  • 1994 PONTIAC TRANS AM
  • 5.7L
  • V8
  • RWD
  • AUTOMATIC
  • 145,000 MILES
I have a 1994 formula one trans am that will not shift into second gear it goes straight from first to third after I let out of the throttle. I unplugged the TPS sensor so it will shift without letting out of the throttle and it does but it skips second and still goes to third. I have also changed out the two shifting solenoids and it still having the same problem. I would like to know what else I could do or check or if I even have second gear anymore? One day I had second gear I just had to let out the throttle for it to shift into it then the next day it just goes into third.
Do you
have the same problem?
Yes
No
Monday, May 15th, 2017 AT 7:07 PM

10 Replies

Tiny
STEVE W.
  • EXPERT
Have you only lost second gear? Do you still have fourth? If you still have fourth gear it is probably a bad 2/4 shift servo. Replace it with a Corvette 2/4 servo or get one of the many servo shim kits and replace the o-rings and shim the servo for higher apply pressure, which is basically what the Corvette part does by design.
If you do not have fourth then it is either a bad 2/4 band or the band retainer in the case.
Was this
answer
helpful?
Yes
No
+1
Tuesday, May 16th, 2017 AT 8:24 AM
Tiny
CHRISFWLR88
  • MEMBER
Thanks a lot y'all I'm probably just going to buy all new rebuild kit with the valve body all the solenoid and just get the vette servo I'm thinking that will do it after y'alls information and expertise. Oh and I do have 4th gear that's why I think the kit will work reply back if y'all have any suggestions on my idea. I am a beginner mechanic but I don't know it all by know means if you know what I mean. Oh and it also comes with a new wire harness.
Was this
answer
helpful?
Yes
No
Tuesday, May 16th, 2017 AT 11:51 PM
Tiny
KEN
  • ADMIN
Hello,

the job is pretty straight forward, here is a guide and some diagrams (BELOW) that should help you get the job done. You will need to drop the pan to get started.

https://www.2carpros.com/articles/how-to-service-an-automatic-transmission

Please let us know what you find ;)

Cheers, Ken

Was this
answer
helpful?
Yes
No
+1
Friday, May 19th, 2017 AT 12:58 PM
Tiny
TONY_713
  • MEMBER
  • 1999 PONTIAC TRANS AM
  • 170,000 MILES
As I shift into first and second gear my trans am seems powerless, it won't accelerate and feels like I'm going 20 mph till I hit about 4th gear. What could be wrong?
Was this
answer
helpful?
Yes
No
Friday, May 19th, 2017 AT 1:35 PM (Merged)
Tiny
HMAC300
  • EXPERT
Take it to a trans shop and have hi m check for codes and make sure trans is full of oil. You may have a bad seal or clutch in thefirst cople of gears. If your trans oil is brownish colored that is onot a good sign and may be burnt up.
Was this
answer
helpful?
Yes
No
Friday, May 19th, 2017 AT 1:35 PM (Merged)
Tiny
TONY_713
  • MEMBER
Well I checked the oil, and it is brownish. I will be doing an oil change to see how that goes, could the oil be the thing affecting the acceleration or is that something other than that?
Was this
answer
helpful?
Yes
No
Friday, May 19th, 2017 AT 1:35 PM (Merged)
Tiny
HMAC300
  • EXPERT
Its a good chance the trans is either got a bad seal or burnt clutches. That is usually what turns the oil brown. Have trans pro look at it they can tell rather quickly
Was this
answer
helpful?
Yes
No
Friday, May 19th, 2017 AT 1:35 PM (Merged)
Tiny
LTKNT
  • MEMBER
  • 2001 PONTIAC TRANS AM
  • 176,300 MILES
I Have an '01 TA with a tranny issue. Starts in 2nd gear and will not shift into 3rd until 35MPH(have to easy off and get back on it). The car is up for a smog test in order to complete registration renewal. Problem is the second have of the test is done at 25MPH. Car will not shift until 35, because of this the RPM ranges goes off scale and causes the test to abort. Is there any way around this, or is there something that maybe the shop tech needs to know? I don't have the money for a transmission rebuild right now and my tags expire this coming tuesday, October 18.
Was this
answer
helpful?
Yes
No
Friday, May 19th, 2017 AT 1:35 PM (Merged)
Tiny
ASEMASTER6371
  • EXPERT
It is internal in the trans. It will have to come out and be checked for the fialure.

Maybe you could try to get a used trans to tempoarily get you going.

Roy
Was this
answer
helpful?
Yes
No
Friday, May 19th, 2017 AT 1:35 PM (Merged)
Tiny
FIXITMR
  • MEMBER
Have you had it scanned at trans shop? Find out what trans you have. Speed sensors are known issues and can be changed externally.
Was this
answer
helpful?
Yes
No
Friday, May 19th, 2017 AT 1:35 PM (Merged)

Please login or register to post a reply.

Recommended Guides