2007 Saturn Relay transmission hesitation

Tiny
HENRYR79
  • MEMBER
  • 2007 SATURN RELAY
  • 93,000 MILES
I have a 2007 Saturn Relay with approx. 110,000 miles on it. The transmission seams to have a hesitation sometimes, not always, after you have been stopped for a light or something. It seems to jump into gear when you start to take off, this hesitation is only a split second long. Does this mean it is about to need to be rebuilt or is it a computer problem or what? What can be done about it?
Do you
have the same problem?
Yes
No
Sunday, October 13th, 2013 AT 3:46 PM

11 Replies

Tiny
SATURNTECH9
  • EXPERT
Have you checked for codes yet?That's where youneed to start.
Was this
answer
helpful?
Yes
No
-2
Sunday, October 13th, 2013 AT 4:38 PM
Tiny
HENRYR79
  • MEMBER
Do you mean codes stored when the check engine light comes on. The light is not on and has never come on.
Was this
answer
helpful?
Yes
No
Sunday, October 13th, 2013 AT 5:55 PM
Tiny
SATURNTECH9
  • EXPERT
I would still check for codes just because you didn't see the light come on doesn't mean there isn't codes. That's where I would start then a transmission pressure test. Has the transmission services been done regularly like there supposed to have been done?
Was this
answer
helpful?
Yes
No
+2
Sunday, October 13th, 2013 AT 6:07 PM
Tiny
HENRYR79
  • MEMBER
Nothing has ever been done to this tranny.
Was this
answer
helpful?
Yes
No
+1
Monday, October 14th, 2013 AT 3:09 AM
Tiny
SATURNTECH9
  • EXPERT
The fluid should have been changed twice already every 50,000 miles.I would have the fluid changed and have them check the transmission pan for debris metal. You could have a plugged filter or a failing transmission. Also have it checked for codes.
Was this
answer
helpful?
Yes
No
+1
Monday, October 14th, 2013 AT 10:09 AM
Tiny
HENRYR79
  • MEMBER
I changed the fluid and filter this past Thursday, the pan was exceptionally clean even the magnet had very little residue on it. The van seemed to work fine for a couple of days and then first thing this morning it did it's hesitation thing again. I have always been told that unless the check engine light is on there would not be any codes stored, if you say there would be, is this the codes that AutoZone or O'Reilly can read for me?
Was this
answer
helpful?
Yes
No
+1
Sunday, October 20th, 2013 AT 4:46 PM
Tiny
SATURNTECH9
  • EXPERT
They maybe able to see it with there code reader. So was the transmission fluid all black?Are you sure its not the engine cutting out instead of the transmission slipping?
Was this
answer
helpful?
Yes
No
+1
Sunday, October 20th, 2013 AT 4:59 PM
Tiny
HENRYR79
  • MEMBER
The fluid looked good, very, very little darkness to it, and like I said the pan was clean. I am sure it is not the engine cutting out.
Was this
answer
helpful?
Yes
No
+1
Sunday, October 20th, 2013 AT 5:16 PM
Tiny
SATURNTECH9
  • EXPERT
You said the fluid hadn't been changed in 110,000 miles so how could it look that good?If the transmission is jumping when taking off then you will have to have the transmission checked out. Pressure test etc. Since its so interment it could just be a solenoid issue.
Was this
answer
helpful?
Yes
No
-1
Sunday, October 20th, 2013 AT 5:23 PM
Tiny
HENRYR79
  • MEMBER
Thanks, I will have it checked out soon. Unbelievable but the fluid did look great. I also have a truck with over 100,000 miles on the tranny since fluid and filter were changed and it still looks great also.
Was this
answer
helpful?
Yes
No
+1
Sunday, October 20th, 2013 AT 6:14 PM
Tiny
SATURNTECH9
  • EXPERT
That's amazing all the fluid I have seen with that kind of miles on it is pretty dark.
Was this
answer
helpful?
Yes
No
-2
Sunday, October 20th, 2013 AT 9:18 PM

Please login or register to post a reply.

Recommended Guides