2006 Ford F-150 06C11 Recall

Tiny
JHILLY1
  • MEMBER
  • 2006 FORD F-150
  • 4.6L
  • V8
  • 2WD
  • AUTOMATIC
  • 106,000 MILES
I have a instrument cluster that cuts on and off along with radio while driving. The recall above is for the instrument cluster recalibration. Something having to do with the abs lights not coming on. I was wondering if this calibration will fix my issue?
Do you
have the same problem?
Yes
No
Tuesday, June 23rd, 2015 AT 6:10 PM

15 Replies

Tiny
JDL
  • EXPERT
At the moment, it sounds like issue with ignition switch? I always check basics first, voltage and ground. There are fuse circuits for both the instrument cluster and radio, where the fuse circuit goes hot with the key on. Gets voltage from ignition switch.
I realize intermittent issues can be a pain, you have to test when problem is ongoing.

At the moment, I don't think that recall is your problem? Just my opinion.
Was this
answer
helpful?
Yes
No
Sunday, June 28th, 2015 AT 9:32 AM
Tiny
JHILLY1
  • MEMBER
I currently dont know what it is. I may do the ignition check. Every so often when I go to start it the truck try to start it turns over but takes about 2-5 seconds to actually start.
Was this
answer
helpful?
Yes
No
Sunday, June 28th, 2015 AT 9:54 AM
Tiny
JDL
  • EXPERT
As far as cranking, if it takes several seconds to start, try cycling the key on and off several times before you crank it. If that helps check your fuel system and fuel pressure. Cycling the key several times may allow the system to pressurize before cranking.
Was this
answer
helpful?
Yes
No
Sunday, June 28th, 2015 AT 10:03 AM
Tiny
JHILLY1
  • MEMBER
Yeah that cranking issue rarely occurs. I took my truck to a ford dealer for the gauge issue. Took them a week to get it to happen again. They checked connections on the cluster and they were good. The fuses and relays were good as well. That was almost a year ago. It didn't do it at all in the winter time now it's summer and it does it every other day. I'm afraid whatever the issue is it will leave me stranded eventually.
Was this
answer
helpful?
Yes
No
Sunday, June 28th, 2015 AT 10:29 AM
Tiny
JDL
  • EXPERT
The problem has to be ongoing when tested or you can't find anything. Hope it doesn't leave you stranded?
Was this
answer
helpful?
Yes
No
Sunday, June 28th, 2015 AT 11:15 AM
Tiny
JHILLY1
  • MEMBER
Yeah cause it's minor now hoping it doesn't turn into a major fix.
Was this
answer
helpful?
Yes
No
Sunday, June 28th, 2015 AT 11:22 AM
Tiny
JDL
  • EXPERT
I understand.
Was this
answer
helpful?
Yes
No
Sunday, June 28th, 2015 AT 1:54 PM
Tiny
JHILLY1
  • MEMBER
Well bud I'm pretty sure I found my problem. I took the paneling off the passenger side interior and found about 2in of water running underneath the wires all the way down the driver side the water was dirty and looked like it's been sitting awhile. Idk where the water came from. Could something from my ac be causing leakage into that area?
Was this
answer
helpful?
Yes
No
Tuesday, June 30th, 2015 AT 5:38 AM
Tiny
JDL
  • EXPERT
It could be your hvac drain has a blockage or water leak around your windshield or body, somewhere?

At the moment, I can't tell if that is effecting your instrument cluster?
Was this
answer
helpful?
Yes
No
Tuesday, June 30th, 2015 AT 7:47 AM
Tiny
JHILLY1
  • MEMBER
I cleaned the water out and I'm gonna see how long it takes the problem to happen again and monitor and see if more water is there at the time of occurrence.
Was this
answer
helpful?
Yes
No
Tuesday, June 30th, 2015 AT 12:06 PM
Tiny
JDL
  • EXPERT
Let us know what you find.
Was this
answer
helpful?
Yes
No
Tuesday, June 30th, 2015 AT 2:35 PM
Tiny
JHILLY1
  • MEMBER
Issue still occurring with water dried up. I have a question though. When I turn the key to the on position all the lights come on in the dash right? After a few minutes most of them go off except the check engine light and battery light. But those two go off after I start it. Is this normal?
Was this
answer
helpful?
Yes
No
Tuesday, June 30th, 2015 AT 7:02 PM
Tiny
JDL
  • EXPERT
That sounds normal.
Was this
answer
helpful?
Yes
No
Wednesday, July 1st, 2015 AT 6:20 AM
Tiny
JHILLY1
  • MEMBER
What about a warm key after taking it out of the ignition is that normal? Never noticed it before
Was this
answer
helpful?
Yes
No
Sunday, July 5th, 2015 AT 4:19 PM
Tiny
JDL
  • EXPERT
That doesn't sound right to me. I don't think I've ever seen that?
Was this
answer
helpful?
Yes
No
Monday, July 6th, 2015 AT 8:46 AM

Please login or register to post a reply.

Recommended Guides