Ignition switch

Tiny
SATURNTECH9
  • EXPERT
  • 30,943 POSTS

The throttle body is only like 86 plus shipping from www. Rockauto. Com it should be that hard to install.I also have a 5 percent discount code from them if your intrested.

Was this
answer
helpful?
Yes
No
Thursday, May 10th, 2012 AT 5:05 AM
Tiny
SEAN03
  • MEMBER

Ok great I want to make sure that it is the throttle body first then I will write you back and let you know. That is the lowest Price that I have seen Thanks. If I put it in and the idel is high how do I make it relearn the throttle. Thanks.

Was this
answer
helpful?
Yes
No
Thursday, May 10th, 2012 AT 12:32 PM
Tiny
SEAN03
  • MEMBER

I am not sure what is up with this truck I started it this morning after I put the battery back in. The truck runs normal. I took it for a 20 minute drive shut it off and I have started it 3 other times today. Any suggestions. If I find that the throttle body is bad I will order it from rock auto. Thanks for your time and help.

Was this
answer
helpful?
Yes
No
Thursday, May 10th, 2012 AT 10:10 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,943 POSTS

You will just have to play it by ear and see if it acts up and go from there.

Was this
answer
helpful?
Yes
No
Friday, May 11th, 2012 AT 4:33 AM
Tiny
SEAN03
  • MEMBER

Ok so I cleaned out the airfilter and some other things The truck idels at 500 rpm which is good. Before I did that it was almost 750- 1000rpm. Before I cleaned the filter out when you started the truck and hit the gas it acts like it wants to die. It still does it after I cleaned everything out. Does this mean that the throttle body may be bad. Thanks.

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 6:17 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,943 POSTS

500 rpms is a little low for a idle speed. Do you have a K and N air filter?

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 6:41 PM
Tiny
SEAN03
  • MEMBER

No it is a fram

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 6:51 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,943 POSTS

Before you cleaned the air filter and did the other things you never mentioned how did it run?

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 8:30 PM
Tiny
SEAN03
  • MEMBER

It ran but it ran heavy. Now it runs smooth. But when you step on the gas and raise the rpms it sounds like it wants to choke.

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 8:42 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,943 POSTS

Lets clear the codes and see which codes come back let me know the exact code numbers and we will go from there.

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 9:19 PM
Tiny
SEAN03
  • MEMBER

I already erased the codes none of them came back up. The codes that came up someone helped me with it. But here are the codes again The code P1682 ignition switch circuit could have been set from crqnking it without it starting and the battery voltage dropping too low. There is a bulletin for that code setting because of that condition. The P0300 is random missfire the P0443 is evap purge solenoid control circuit. The P0102 is mass air flow sensor performance. The P0102 can be caused by the same reason the P1682 can low battery voltage.I would have the battery tested make sure the alternator is charging properly also make sure the battery cables are clean and tight. Also have a back pressure test done to make sure you dont have a plugged cat. That could set a random missfire code the mass air flow code etc. Thanks.

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 9:47 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,943 POSTS

Thats what I said that you copied and pasted. While the engine is idling try lightly taping on the with a screwdriver handle on the mass air flow sensor see if the engine runs any different from doing that.

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 9:54 PM
Tiny
SEAN03
  • MEMBER

Ok thanks. I will try it and let you know. If it does change what does that meen. Thanks for your time and help.

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 10:00 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,943 POSTS

Loose connection to the mass air flow sensor or a bad mass air flow sensor. Let me know what you find.

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 10:02 PM
Tiny
SEAN03
  • MEMBER

On that not I forgot my next door neighbor was helping me. He pushed on one of the connectors and it snapped in. I dont know the name of it but it finally corrected itself. Tat was when I first started working on it a week ago. Now it is just trying to dye when you touch the gas. Thanks.

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 10:23 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,943 POSTS

Alright keep me posted on what you find.

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 11:51 PM

Please login or register to post a reply.

Recommended Guides