Chucking chev Impala 06 LT 3500

Tiny
ATOPPING1978
  • MEMBER
  • 2006 CHEVROLET IMPALA
  • 145,000 MILES
2006 chev impala lt-145k have already replaced spark plugs, coil pack, oil change, crank sensor and the car is still chucking when driving or idling. No codes on the gm reader after fixing the sensor. Car still chucking and quitting when revved in park. Can drive down the road and there is almost no gas pressure then bang, it takes off but keeps chucking. The engine feels like its going to quit and sometimes it does. Please help me, Amy
Do you
have the same problem?
Yes
No
Saturday, August 25th, 2012 AT 6:24 PM

3 Replies

Tiny
DRCRANKNWRENCH
  • MEMBER
You might have a clog in the fuel filter which is in the fuel tank. It is unlikely. If your car has a secondary fuel filter, which will be near the fuel tank or in the engine bay, you should replace it as it may be clogged.
Otherwise you may want to think about replacing the fuel pump. If you have tested the fuel pressure, and you should if you have not, and it is low at any point. There is either a clog in the line or the pump is bad.
Was this
answer
helpful?
Yes
No
Saturday, August 25th, 2012 AT 6:36 PM
Tiny
ATOPPING1978
  • MEMBER
The fuel system reads 'ready' when on the computer. The gas tank was replaced last year along with the exhaust or muffler I guess. My mechanic has been trying everything and I'm now trying to help him by asking around lol he has been in business for 30 years and can't figure it out.

Problem is the bill keeps going up and the car still isn't fixed.

Any other suggestions? What about the fuel pedal sensor? Would that cause this to happen?
Was this
answer
helpful?
Yes
No
Saturday, August 25th, 2012 AT 6:49 PM
Tiny
ASEMASTER6371
  • EXPERT
Fuel system ready has nothing to do with the condition of the pump. What is the actual fuel pressure?

Roy
Was this
answer
helpful?
Yes
No
Saturday, August 25th, 2012 AT 7:11 PM

Please login or register to post a reply.

Sponsored links