No forward gears

Tiny
ANONYMOUS
  • MEMBER
  • 2006 CHEVROLET IMPALA
My car will reverse but wont drive forward what causes this problem
Sunday, February 17th, 2013 AT 3:17 AM

6 Replies

Tiny
MHPAUTOS
  • EXPERT
This sounds like you have a transmission gear position sensor that is out. Here is the location so you can change it out. # 811 on the diagrams below.

Check out the diagrams (Below). Please let us know what happens.

Cheers
Was this
answer
helpful?
Yes
No
Sunday, February 17th, 2013 AT 3:21 AM
Tiny
JERRYSWINDSOCKS
  • MEMBER
Thanks for the post I wish I got here earlier the shop charged my $280.00 to do the job.
Was this
answer
helpful?
Yes
No
Saturday, August 18th, 2018 AT 8:16 PM
Tiny
JAYDUBIOUS13
  • MEMBER
  • 2004 CHEVROLET IMPALA
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 105,000 MILES
My car ran temperature of 190 -200 degrees about three miles and we made quite stop and started up and went four blocks when the transmission just quite working. I checked the oil and did not smell burnt or hot. The transmission would not work in any gears forward or backwards. I heard a dragging sound or rubbing bur nor sure where it is coming from. The next day I drove it around the block and the transmission just stopped on the fourth block like you put it it neutral. The motor rpm's come up, but nothing happens. I cannot see any wires off anywhere. Any ideas what I could look for? Thanks, David
Was this
answer
helpful?
Yes
No
Monday, August 20th, 2018 AT 9:06 AM (Merged)
Tiny
MASTERTECHTIM
  • MEMBER
David unfortunately I think it blew up.
Was this
answer
helpful?
Yes
No
Monday, August 20th, 2018 AT 9:06 AM (Merged)
Tiny
PEANUTG13
  • MEMBER
  • 2007 CHEVROLET IMPALA
  • 120,000 MILES
I drove my car and I tried to reverse but it wouldnt go, so I pushed it back and went forward but it started to shake. I looked at the tranny fluid and it was pretty low. So I got it towed to my house and I fill the fluid. I ran the car around the block to make sure it still works and it worked fine. So I took it out to go to the store about 11 miles down, the car wouldnt go anymore, I pushed the gas and it just revved. So I pulled over and checked fluid, and the fluid was all there. I stayed put for about 20 minutes and then turned the car back on and put it in drive and drove about 500 ft and it did it again, it started revving, so I got it towed to my house again. I want to know what is going on.
Was this
answer
helpful?
Yes
No
Monday, August 20th, 2018 AT 9:06 AM (Merged)
Tiny
ASEMASTER6371
  • EXPERT
You need to have the transmission overhauled. There is nothing external you can do at this point.

Roy
Was this
answer
helpful?
Yes
No
Monday, August 20th, 2018 AT 9:06 AM (Merged)

Please login or register to post a reply.

Recommended Guides