Front windshield wipers not working

Tiny
BEOPNL
  • MEMBER
  • 2005 VOLVO XC90
  • 2.5L
  • 5 CYL
  • TURBO
  • AWD
  • AUTOMATIC
  • 84,000 MILES
I recently bought this car and the front wind shield wipers are not working at all, but the rear wiper and windshield spray are working. I tried to change the relays and fuses also replaced the front wiper motor and still nothing. Please let me know what could it be. The windshield wipers suddenly stop working from time to time. They will be operating perfectly, then they will just stop. When I turn the engine off, remove the keys, then restart the car, they seem to work fine again. Any suggestions as to a cause/cure for this? This model has the "auto" feature on the wipers, but the wipers shut off in any mode, with the auto feature turned on or off.
Do you
have the same problem?
Yes
No
Saturday, February 15th, 2014 AT 5:05 PM

9 Replies

Tiny
HMAC300
  • EXPERT
Hello,

There are three fuses and two relays that run the system. You must be losing power or the wiper motor is out let's find out which. Please check out these guide and then come back to check out the diagrams below.

https://www.2carpros.com/articles/how-to-check-a-car-fuse

and

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

and

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Here are the diagrams for the windshield wiring and fuses

Check out the diagrams (Below)

Please let us know what you find. We are interested to see what it is.

Cheers
Was this
answer
helpful?
Yes
No
+1
Sunday, February 16th, 2014 AT 8:00 AM
Tiny
JIS001
  • EXPERT
You may want to start with a central electronic mudule software update to see if these will correct the problem. These can be done at a dealership or any shop that has that capability of downloading software.
Was this
answer
helpful?
Yes
No
+1
Friday, January 20th, 2017 AT 4:00 PM (Merged)
Tiny
JULIANCELLO
  • MEMBER
  • 2005 VOLVO XC90
  • 2.5L
  • V6
  • 2WD
  • MANUAL
  • 95 MILES
The front wind shield wipers are not working at all, but the rear wiper and windshield spray are working. I tried to change the relays and fuses. Also, replace the front wiper motor and still nothing. Please let me know what could it be.
Was this
answer
helpful?
Yes
No
+1
Friday, January 20th, 2017 AT 4:00 PM (Merged)
Tiny
JOHNNYT73
  • EXPERT
It sounds like you have a wiper motor that is out, Can you use this guide to check for power?

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Use the diagrams above please
Was this
answer
helpful?
Yes
No
-1
Friday, January 20th, 2017 AT 4:00 PM (Merged)
Tiny
JULIANCELLO
  • MEMBER
Thank You for answering I really appreciate it. I already did changed the switch, but still nothing. So I check for power at that motor and it is getting power. But not moving is the motor bad?
Was this
answer
helpful?
Yes
No
Friday, January 20th, 2017 AT 4:00 PM (Merged)
Tiny
JOHNNYT73
  • EXPERT
It sure sound like it here are some diagrams (below) to help you get it changed out.

Please let us know what happens.

Cheers
Was this
answer
helpful?
Yes
No
Friday, January 20th, 2017 AT 4:00 PM (Merged)
Tiny
JULIANCELLO
  • MEMBER
Thank you again! That worked installed a new motor and bam! Its working thanks 2Carpros
Was this
answer
helpful?
Yes
No
Friday, January 20th, 2017 AT 4:00 PM (Merged)
Tiny
JOHNNYT73
  • EXPERT
Glad you could get it fixed, that kind of problem can be tough. Please use 2CarPros anytime we are here to help

Cheers
Was this
answer
helpful?
Yes
No
+1
Friday, January 20th, 2017 AT 4:00 PM (Merged)
Tiny
JULIANCELLO
  • MEMBER
I will :)
Was this
answer
helpful?
Yes
No
Friday, January 20th, 2017 AT 4:00 PM (Merged)

Please login or register to post a reply.

Recommended Guides