Wont start please help!

Tiny
MARRERO412002
  • 2005 NISSAN ARMADA
  • 87,000 MILES

Ok well let me start this story I have a 05 armada which I was charging the air compressor for the ac. Now this is where this went downhill and its freaky me the hell out. When me and my mechanic where injecting the gas to the ac lines he tells me to go turn off the truck I go to try and turn the truck on and it doesn't want to start. Try it again no go. Ok so we check whats going on so we start checking all the fuses probably on went out. Nothing all fuses are indicating they are ok. Next we check the fuel pump under the passenger seat behind the drive look ok. Next we check the gas line to see for pressure working good. So at this point its 11pm and we are like what the hell just happened. Next day he comes back we keep on searching im on the internet I see armada owner stating that it could be a ecm relay that was on recall I call the dealership they say yeah so I go and buy the relay which was 4 bucks and plug it in no start. Next day my mechanic get his buddy that owns a shop and bring a ob ii reader basically a diagnosis and when we plug in the machine to the truck ob ii keeps saying please turn car on mind you the car power is on. Stating no connection with truck whats over so he then tell me probably the trucks doesn't recognize the key. So im like ok let me get this locksmith that programs key to see if that's the problem he comes try to hook up to the car same thing on his computer no connection please turn car on. Car is powered on so he could not help me either. Ok so if someone please reply if they had this problem please help me before I have to step into the dealer I have a guy that told me it could be the truck computer that went out but the car navi and power up ok just doesn't want to start. Current status of the truck the most recent thing we found out is
1. That I am not getting no sparks on spark plugs.
2. When the car is on I am getting vso, slip, read key stays lite
ac fan just keeps running constantly, and emergency brake stats it on when really if not in.
3. No check engine light turns on when I power up car. You know when turn on the truck all light goes on and then the turn off the only light that doesn't come on is the check engine light.
4. Things I performed already
5. Checked all fuses ok
6. Replace the ecm relay
7. No diagonals could be performed
8. Check module connector port stats the connector is okay

Do you
have the same problem?
Yes
No
Saturday, July 7th, 2012 AT 4:04 PM

5 Replies

Tiny
2CARPROS KEN
  • ADMIN
  • 7,635 POSTS

Hello,

It sounds like the crankshaft angle sensor has gone out and needs to be replaced which is common on these cars.

Here is a guide to show you what you are in for when doing the job and a diagram (BELOW) of where the sensor is on your car.

https://www.2carpros.com/articles/crankshaft-angle-sensor-replacement

Please let us know what happens. I am curious ;)

Cheers, Ken

Was this
answer
helpful?
Yes
No
Friday, May 26th, 2017 AT 6:27 PM
Tiny
BEONVAL
  • 2004 NISSAN ARMADA
  • 5.8L
  • V8
  • AUTOMATIC
  • 120,000 MILES

Hello, I replaced my battery in my car this morning and now it won't start. The engine won't turn over and the dash lights won't light. The only light on the dash is a red car icon with a key in the middle. The cables are tight

Was this
answer
helpful?
Yes
No
Friday, May 26th, 2017 AT 6:28 PM (Merged)
Tiny
HMAC300
  • EXPERT
  • 49,211 POSTS

Try resetting your anti theft if no manual look online it was set because you disconnected battery

Was this
answer
helpful?
Yes
No
Friday, May 26th, 2017 AT 6:28 PM (Merged)
Tiny
DAVID ELEMI
  • 2003 NISSAN ARMADA
  • 5.6L
  • V8
  • 4WD
  • AUTOMATIC
  • 180 MILES

The car was towed to my shop, but I learned that the car was not starting hence a new engine was replaced from another Armada car. Nisan Armada Vk56DE; the car is cranking, I timed the car now current is coming as well as fuel. Engine was backfiring from the intake while cranking but what I observed is that all the spark-plug is wet with fuel since the car is sensor throttle I depressed the throttle completely to the floor. Engine is also compressed but it is not starting.

Was this
answer
helpful?
Yes
No
Friday, May 26th, 2017 AT 6:28 PM (Merged)
Tiny
STEVE W.
  • EXPERT
  • 2,304 POSTS

It sounds like the engine is not getting spark in time. What year did the replacement engine come from? My interchange sheet says the 2003-2006 engines are the same but changes were made in late 2006 that made those and later engines unusable in the earlier trucks as the control systems changed.

Was this
answer
helpful?
Yes
No
Friday, May 26th, 2017 AT 6:28 PM (Merged)

Please login or register to post a reply.

Related Engine Not Starting Questions

Recommended articles