2004 Chrysler Crossfire Car won't start

Tiny
BRANDON09
  • MEMBER
  • 2004 CHRYSLER CROSSFIRE
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 42,000 MILES
Yesterday my car drove fine. Today my car won't start.

When I first tried starting the car I didn't get the sound of the car turning over, not a beep, not a click, but what did happen is all the lights came on normally, and the spoiler deployed until I stopped turning the key. Once the spoiler had fully deployed now when I try to start the car I get a clicking noise and all the lights flash, including the headlights, but because of some problem with the plastic of my headlights being filmy I can't tell if the lights are dimming at all. I have a friend coming over to give me a jump start and if it won't jump the first time, we won't continue. Everything is telling me on a normal car it would likely be the starter but the crazy spoiler deploying is what gets me. Even now when I try to turn the car on the LED in the center console for the spoiler flashes. It is the only center console LED to light up too. So what is my problem? And if it is my starter, I can't even find it, how do I replace it?
Do you
have the same problem?
Yes
No
Friday, July 10th, 2009 AT 11:09 AM

5 Replies

Tiny
ACBB
  • MEMBER
How did you fix it? I am currently having the exact problem.

Cheers.
Was this
answer
helpful?
Yes
No
+1
Thursday, March 24th, 2011 AT 6:51 AM
Tiny
BRANDON09
  • MEMBER
I replaced the battery, it was too dead to hold a charge and jump starting it didn't work when my friend came over. I may have been able to have AAA successfully jump the car but the battery was unable to regain a charge. It was NOT caused by anything other than the battery.
Was this
answer
helpful?
Yes
No
Thursday, March 24th, 2011 AT 4:42 PM
Tiny
SDENDY
  • MEMBER
I've had this same issue. So I took it to Auto Zone to get the battery and the alternator checked. They told me that the battery was at 97% and that my alternator was running at 100%. I get so upset b/c I never know when that car is gonna start or not start. It does it randomly. Any other suggestions? Maybe it is my starter?
Was this
answer
helpful?
Yes
No
+2
Saturday, August 6th, 2011 AT 2:12 AM
Tiny
JONLEACH
  • MEMBER
Sdendy, did you ever get anywhere? I'm having the same problem as you, and it's not the battery or alternator.
Was this
answer
helpful?
Yes
No
-1
Friday, December 9th, 2011 AT 9:31 PM
Tiny
RASMATAZ
  • MEMBER
TO: jonleach

http://www.2carpros.com/articles/car-cranks-but-wont-start

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine atleast 3/16 away from ground-have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, Do you hear the fuel pump come On when you turn key on? If not check fuel pump fuse and fuel pump relay if okay-check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs,coil's resistances,cap and rotor,distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it and keep testing

If both fuel and spark is present-check the valve and ignition timing, this will lead you to problems

with compression and valves opening and closing at the wrong time/broken or jumped timing

belt/chain.
Was this
answer
helpful?
Yes
No
Saturday, December 10th, 2011 AT 9:48 AM

Please login or register to post a reply.

Recommended Guides