RADIO GETTING NO POWER...ANY SUGGESTIONS??

2003 Nissan 350Z

Tiny

joshuapanchisin

August, 9, 2012 AT 1:04 PM

2003 350Z. Installing an aftermarket radio and it is not getting any power what so ever. Re-Checked the wiring which is correct and also checked the interior fuse panel radio fuse and it was fine. Any suggestions?

FOUND 499 RELATED QUESTIONS

I Think That I Blew A Fuse

24 ANSWERS
4 IMAGES

Stereo Fuse

1 ANSWER

7 Answers

Tiny

ASEMaster6371

August, 9, 2012 AT 1:10 PM

Power is key on 12volts. I would re check fuses with a test light to confirm.

Roy

Tiny

joshuapanchisin

August, 9, 2012 AT 1:15 PM

How many fuses is there that powers the radio? I checked the one on the interior fuse panel, but is there one in the fuse panel under the hood?

Tiny

rasmataz

August, 9, 2012 AT 1:15 PM

Check if the radio unit has a blown fuse-make sure the wiring connector is attached properly

Tiny

joshuapanchisin

August, 9, 2012 AT 1:18 PM

I checked the wiring over multiople times and it is done properly, and the fuse on the radio is fine. Is there something under the hood that I should be checking?

Tiny

rasmataz

August, 9, 2012 AT 1:27 PM

Check fuses below

Tiny

joshuapanchisin

August, 9, 2012 AT 1:37 PM

Thanks, I will give it a try

Tiny

KHLow2008

August, 9, 2012 AT 1:50 PM

At the radio connector, there must be 2 wires with battery voltage with ignition switch turned on, Light Green and Yellow.

With ignition switch off the Yellow wire should have battery voltage.

Please login or register to post a reply.

Door Panel Removal & Speaker Replacement
Cabin Air Filter Replacement