MY CAR STALLS A LOT AFTER INSTALLING A MUSIC SOUND SYSTEM

2005 Nissan 350Z

Tiny

ali_timon

November, 15, 2011 AT 8:54 AM

I recently got a 350z 2005 speed6 manual and ever since I fixed a sound system, it just turns on but when I rev on N or even first gear, the car almost sounds like it back fires and switches off? I had the fuel pump checked but this only happened after installing the music sound system literally!
i dont have a clue on what to do I hope someone can help me : (


FOUND 2827 RELATED QUESTIONS

7 Answers

Tiny

mhpautos

November, 15, 2011 AT 9:26 AM

I would be re checking the wiring of the sound system, if it has started acting up straight after the sound system installation, I would start here, also run a diagnostic check just to check for any unresolved fault codes, was the battery disconnected during the sound system installation?

Tiny

KHLow2008

November, 15, 2011 AT 2:17 PM

Check ground circuits for secureness. During installation of the sound system, some ground circuit could have been tampered and not retorqued correctly.

Tiny

ali_timon

November, 27, 2011 AT 5:23 PM

Hey guys sorry for the late reply. Ive done a computer check and discovered the fault
2 a/f sensors which is the fault but I am still not sure if that causes the car to stall!
I have sent it now to get all the wires replaced! I think its the airflow sensor. Might get a jet performance a/f sensor

mhpautos the battery was not disconnected

Tiny

KHLow2008

November, 27, 2011 AT 5:32 PM

Keep us updated on the progress.

Tiny

ali_timon

November, 27, 2011 AT 5:33 PM

Will do. Thanks a lot : D

Tiny

ali_timon

January, 20, 2012 AT 10:55 PM

I had the whole wiring changed and the car is running perfectly. Thanks a lot

Tiny

KHLow2008

January, 21, 2012 AT 11:38 AM

You're welcome.

Have a great day.

Please login or register to post a reply.

Door Panel Removal & Speaker Replacement
Cabin Air Filter Replacement
Cabin Air Filter Replacement Chevrolet Tahoe