NO HEAT

2003 Ford Explorer

Tiny

nik0las3

September, 23, 2011 AT 12:53 AM

Hi,

I am not getting heat in my 2003 ford explorer. First I replaced the blend door actuator motor and blend door in plenum box with heater treater parts and solved that problem. My blend door actuator had broken. The blower works and the two hoses going to the heater core are hot. I replaced the thermostat and the heater control valve. I also back flushed the heater core. When I back flushed the heater core it flowed fine it did not seem to be restricted. Any advice would be greatly appreciated.

Thanks
Nick

FOUND 4982 RELATED QUESTIONS

No Heat

37 ANSWERS
5 IMAGES

5 Answers

Tiny

ASEMaster6371

September, 23, 2011 AT 1:02 AM

Does the actuator work now? It is the most common issue with fords

Roy

Tiny

nik0las3

September, 23, 2011 AT 1:21 PM

Yes the actuator and blend door are working.

Tiny

ASEMaster6371

September, 23, 2011 AT 1:41 PM

Hoses are hot, blend door working, thermostat good, ok, I know you flushed the core but it sounds like there is not enough flow to give you heat. Take it to a radiator shop and have them flush it with an acid flush to see if they can unclog it.

Roy

Tiny

nik0las3

September, 23, 2011 AT 2:21 PM

Thanks alot I will look into that. I would not have thought of that. I appreciate you responding to my problem.

Tiny

ASEMaster6371

September, 23, 2011 AT 2:27 PM

Good luck

Roy

Please login or register to post a reply.

Blend Door Actuator Replacement
Heater Hose Replacement Chevrolet Camaro
Cabin Air Filter Replacement Chevrolet Tahoe
Cabin Air Filter Replacement Saturn Vue
Cabin Air Filter Replacement Honda Civic
Cabin Air Filter Replacement