2002 Saturn SL1 Poor sluggish acceleration

Tiny
FISHFLAT
  • MEMBER
  • 2002 SATURN SL1
  • 1.9L
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 135,000 MILES
When cold runs great. Once temp reached, acceleration is very poor. Get past 35-40 mph seems to improve
Tried so far: new intake gasket( it was in pieces), fuel and air filter, sea foam, manifold air pressure sensor, oil, cleaned EGR, checked for vac leaks, new brass temp sensor, punched converter.
Some improvement, but still sluggish
Thanks in advance
Henry
Do you
have the same problem?
Yes
No
Thursday, April 17th, 2014 AT 1:00 PM

8 Replies

Tiny
SATURNTECH9
  • EXPERT
Theres two cats on that car one in the exhaust manifold and one under the car.I would do a back pressure test on the exhaust sounds a lot like a restricted exhaust.
Was this
answer
helpful?
Yes
No
Thursday, April 17th, 2014 AT 1:17 PM
Tiny
FISHFLAT
  • MEMBER
Is it actually inside the exhaust manifold?
Thanks
Henry
Was this
answer
helpful?
Yes
No
Thursday, April 17th, 2014 AT 2:44 PM
Tiny
FISHFLAT
  • MEMBER
Also at the exhaust pipe. It sounds like a poor running lawn mower after temp reached. Not steady, just putt, putt, putt and so on
Thanks
Was this
answer
helpful?
Yes
No
Thursday, April 17th, 2014 AT 2:48 PM
Tiny
FISHFLAT
  • MEMBER
Ok.I do see the canister on the manifold. I'll check it tomorrow and post back. Your advice is extremely appreciated. I will check in tomorrow
Thanks
Was this
answer
helpful?
Yes
No
Thursday, April 17th, 2014 AT 3:03 PM
Tiny
SATURNTECH9
  • EXPERT
What usually happens on the manifolds is the cat breaks loose and cloggs the down pipe. Keep me posted.
Was this
answer
helpful?
Yes
No
Thursday, April 17th, 2014 AT 8:58 PM
Tiny
FISHFLAT
  • MEMBER
Ok. The manifold cat is cleared. Some improvement.
There is still extremely slow acceleration from a stop and up to 35mph.
After reaching 35mph you can hit the gas and it runs and performs perfectly.
It also performs well when cold. When temp is reached it Boggs on acceleration until 35mph then it runs perfectly.
Also have installed plugs and wires. Forgot that on initial post.
Thanks
Was this
answer
helpful?
Yes
No
Friday, April 18th, 2014 AT 12:26 PM
Tiny
SATURNTECH9
  • EXPERT
What kind of plugs did you put in?Also did you route the spark lg wires correctly?They will run weird if there not routed correctly. Also have you checked compression yet on all the cylinders?What is your actual fuel pressure? Before you go punching out cats you shoukd have check the actual back pressure of the exhaust.
Was this
answer
helpful?
Yes
No
Friday, April 18th, 2014 AT 12:43 PM
Tiny
SATURNTECH9
  • EXPERT
Also you shouldn't be punching out cats to begin with thats against the law.
Was this
answer
helpful?
Yes
No
Friday, April 18th, 2014 AT 12:44 PM

Please login or register to post a reply.

Recommended Guides