IS MY TRANSMISSION BAD?

2002 Mercury Sable

Tiny

jvelazquez

May, 31, 2012 AT 10:00 PM

I have a 2002 Mercury Sable. Well, today I was backing up from my driveway normal like every day but today I guess I shifted it to drive without it stopping completely plus I accelerated a little bit too. Then I heard like a "boom" noise and after that a yellow light with an exclamation point started blinking. Also when I accelerate it, it trembles or shake and hesitate to go or accelerate. After a few seconds of hesitation it starts to get more force and it drives normal until I stop on a light or a stop sign then it will do it again. What could it be? Please help!

FOUND 87 RELATED QUESTIONS

7 Answers

Tiny

ASEMaster6371

May, 31, 2012 AT 10:51 PM

You have an internal failure. It most likely will have to come out to determine the failure.

Roy

Tiny

jvelazquez

June, 1, 2012 AT 1:35 AM

What needs to come out the transmission? What internal failure could be?

Tiny

ASEMaster6371

June, 1, 2012 AT 1:43 AM

Front clutch, planetaries, low sprag and any and all moving items related to low gear.

Roy

Tiny

jvelazquez

June, 1, 2012 AT 3:34 PM

I took my car to a mechanic and he checked the car and he put it in the machine and all the engine and transmission codes appeared and he said that my transmission might not be the problem but the computer. How true can that be? I also noticed once my car is running it wont change shifts. Can the computer control all that or this mechanic is fishy?

Tiny

ASEMaster6371

June, 1, 2012 AT 3:41 PM

Mechanic may not be familiar with how the trans works. Get another opinion from a trans shop to confirm. I still think you have internal issues.

Roy

Tiny

CamyPud418

July, 24, 2012 AT 9:29 PM

I had to take 2004 Mercury Sable and I took it in today for the same reasons minus the loud noise. The hesitation and not shifting gears when accelerating. My diagnostic test said to be misfires. The mechanic said it could be anything from a new computer or something as minor as a tuneup. Any luck with your car since?

Tiny

jvelazquez

July, 24, 2012 AT 11:18 PM

Well I took it to a mechanic and he said it wasn't the transmission and he changed the coil and cables and the car worked for a month and a half then did it again. (I didn't mentioned that my car had the engine light on for a while prior to all this)so after he changed what he changed even the engine light was gone for a few weeks then it came up again and a month after the engine light came up again the car started doing all I mentioned in my other questions. I took it back like a week or 2 ago and he said that it was the mass air flow sensor. I haven't change it yet because he took the cables back out and spray cleaned everything and the car is running good except that the engine light is back on. So before it does it again I will change my mass air flow sensor which I checked online what the symptoms are for a defective mass airflow sensor and they are very very similar to my car symptoms.

Please login or register to post a reply.

Code Read Retrieval/Clear Scion XD
Code Read Retrieval/Clear - Dodge Stratus
 Step by Step video GMC Yukon XL 2000-2006
Read Codes Like a Pro
Code Read Retrieval/Clear Chevrolet Camaro
How to read codes Chevrolet Blazer
Code Read Retrieval/Clear Mercedes-Benz C230