2001 Mitsubishi Galant my car wont start compeltly

Tiny
CHEYANNE007
  • MEMBER
  • 2001 MITSUBISHI GALANT
  • 133,367 MILES
I just had the valve cover gaskets replaced, as that was being done it it was brought to my attention that oil had gotten up where the sparkplugs are so I had those replaced to. Now for the second time when I first go to start my car in the morning it won't start completly. Its like its not catching. But if I rev the engine for 45 seconds its starts up just fine and once I start driving it the idle smooths out and it runs just fine. I can turn it off and it will start back up. But its only when I first start it up in the morning do I have any grief. Any help would be appreciated.
Do you
have the same problem?
Yes
No
Wednesday, September 4th, 2013 AT 3:50 AM

9 Replies

Tiny
MHPAUTOS
  • EXPERT
Try cycling the fuel pump twice before starting and see how that helps.
Was this
answer
helpful?
Yes
No
Wednesday, September 4th, 2013 AT 5:05 AM
Tiny
CHEYANNE007
  • MEMBER
How do I do that?
Was this
answer
helpful?
Yes
No
Wednesday, September 4th, 2013 AT 5:23 AM
Tiny
MHPAUTOS
  • EXPERT
Turn key to on, do not crank, wait 2-3 sec then turn off and then do same but after 2-3 sec try starting, this will get full fuel rail pressure up, the problem may be fuel rail pressure dropping off to fast.
Was this
answer
helpful?
Yes
No
Wednesday, September 4th, 2013 AT 5:30 AM
Tiny
CHEYANNE007
  • MEMBER
Nope did not work.
Was this
answer
helpful?
Yes
No
Wednesday, September 4th, 2013 AT 5:41 AM
Tiny
MHPAUTOS
  • EXPERT
Ok, just a thought, check fuel pressure and make sure that the correct spark plugs have been fitted, has this problem just started since the plugs were fitted?
Was this
answer
helpful?
Yes
No
Friday, September 6th, 2013 AT 5:12 AM
Tiny
CHEYANNE007
  • MEMBER
Yes I got my car back Monday and Tuesday morning is when this started happening.
Was this
answer
helpful?
Yes
No
Friday, September 6th, 2013 AT 9:21 PM
Tiny
MHPAUTOS
  • EXPERT
I would check that the plugs are the correct type and that the gas are correct, is there any misfiring when it is running?
Was this
answer
helpful?
Yes
No
Saturday, September 7th, 2013 AT 6:50 AM
Tiny
CHEYANNE007
  • MEMBER
I think so, its been running a lil rough. I know its been drinking gas where before it was awsome on gas.
Was this
answer
helpful?
Yes
No
Saturday, September 7th, 2013 AT 7:12 AM
Tiny
MHPAUTOS
  • EXPERT
Check the plug, make sure that they are correct.
Was this
answer
helpful?
Yes
No
Saturday, September 7th, 2013 AT 7:15 AM

Please login or register to post a reply.

Sponsored links