2000 Chrysler Town and Country sound and smell

Tiny
JACARA
  • MEMBER
  • 2000 CHRYSLER TOWN AND COUNTRY
  • 2WD
  • AUTOMATIC
  • 145,000 MILES
When I got off work today I smelled a rubber burning smell from my hood when I turned my heat off I don't smell it but on I did I am sure the smell was still there. I drove to the store then home on way home it started to make a whining sound. I got back in it like 40 min later nrove down street and the whining sound was louder and the brunning smell was still there. Can you please narrow it down to what wrong. Thank you for your time
Do you
have the same problem?
Yes
No
Tuesday, March 4th, 2014 AT 6:17 PM

4 Replies

Tiny
HMAC300
  • EXPERT
Open your hood and see if the belt is shot if it is replace the belt and tensioner.
Was this
answer
helpful?
Yes
No
Wednesday, March 5th, 2014 AT 6:59 AM
Tiny
JACARA
  • MEMBER
Ok thank you I'll see if that is bad. But I was on way to work today and my battery light came on and the smell still there I turned my car off and now it won't start and last Wednesday I got my alternator rebuilt so could it still be bad and that why it smells to? Thank you guys do much
Was this
answer
helpful?
Yes
No
Wednesday, March 5th, 2014 AT 7:36 AM
Tiny
HMAC300
  • EXPERT
Have it checked it's either misaligned and burnt it up or there is something else doing it. Have a local guy check it or wher eyou had alternator fixed.
Was this
answer
helpful?
Yes
No
Wednesday, March 5th, 2014 AT 7:38 AM
Tiny
JACARA
  • MEMBER
Ok thank you so much !
Was this
answer
helpful?
Yes
No
Wednesday, March 5th, 2014 AT 7:40 AM

Please login or register to post a reply.

Sponsored links