VAN WONT START ... JUST QUIT WHILE DRIVING

2000 Chevrolet Astro

Tiny

bentdesign

October, 7, 2012 AT 10:28 PM

2000 chevy astro! Fuel problems. Checked coil good. Took out fuel pump, had it tested good! Grounding problem maybe? Is there an auxilary ground somewhere? Solid black is the ground? Everything else shows current? I'm lost

FOUND 25377 RELATED QUESTIONS

Cj Stalling When Idling

33 ANSWERS
44 IMAGES

Stalling Out

43 ANSWERS
48 IMAGES

12 Answers

Tiny

saturntech9

October, 7, 2012 AT 10:36 PM

So you have a nice blue spark?What your actual fuel pressure?Do you have injector pulse?Any codes in the computer?

Tiny

bentdesign

October, 7, 2012 AT 11:29 PM

Blue spark yes. Fuel pressure none because fuel pump doesn't turn on. I don't know about the rest. Originally had evap code but doesn't show any right now but engine light still on

Tiny

bentdesign

October, 7, 2012 AT 11:32 PM

Tried new coil everything the same changed all relays and fuses tested all wires ground light on then goes off is there a secondary place ground gets grounded

Tiny

saturntech9

October, 7, 2012 AT 11:35 PM

So the fuel pump is inop but you bench tested it and it worked?

Tiny

bentdesign

October, 8, 2012 AT 5:31 PM

Yes

Tiny

saturntech9

October, 8, 2012 AT 5:56 PM

Find the inline connector going to the gas tank unplug it on the harness side check terminal c it should be a constant ground. Now check terminal b the grey wire it should have power while cranking the engine. Let me know what you find.

Tiny

bentdesign

October, 8, 2012 AT 5:57 PM

Did that no power on ground power on others while cranking

Tiny

saturntech9

October, 8, 2012 AT 6:05 PM

Did you check the gray wire for power by usuing the frame rail for the black test lead and the red test lead to the gray wire while cranking?ALso was the black wire terminal c a constant ground?Your reply was all blurred together hard to tell what yoou were trying to say.

Tiny

bentdesign

October, 8, 2012 AT 6:16 PM

Sorry tested all wires there was power while cranking no power on ground wire

Tiny

saturntech9

October, 8, 2012 AT 6:22 PM

Alright there isnt supposed to be power on the ground wire. Was there 2 ohm or less to ground on the terminal c ground wire?If not you will have to start by fixing that.

Please login or register to post a reply.

How to gather codes Ford Explorer
Code Read Retrieval/Clear - Dodge Stratus
Read Codes Like a Pro
Code Read Retrieval/Clear Mercedes Benz
Code Read Retrieval/Clear Mercedes-Benz C230
Code Read Retrieval/Clear Chevrolet Camaro