Heater not working

Tiny
ANONYMOUS
  • 1999 TOYOTA AVALON
  • 250 MILES

No heat in my 1999 Avalon. Both heater core hoses (in and out) get hot, however, no heat when I move heat/ac control on the inside panel nor when I manually adjust the control on the Heater control valve near the firewall (engine). Also, the cable from the control panel to the Heater control valve does not move when I change the temp control inside the car. The coolant level is good and the temp gauge registers halfway between hot and cold (normal).

Any ideas of what is stopping my heat? I am having the same issue with my 99 Avalon. I have flushed the heater core, unhooked the water control valve and opened it manually but still no heat. I can't move the cable from outside nor will it move with temp control knob. I found a control unit in salvage yard no change. All buttons on both control units seem to move to correct positions but hot air no idea what to try next.?

Saturday, November 17th, 2012 AT 5:27 AM

5 Replies

Tiny
2CARPROS KEN
  • ADMIN
  • 11,755 POSTS

Hello,

This sounds like a problem with your temperature blend door actuator not working anymore. Here are two guides that will help us get the problem fixed. This guide will show you what you are in for changing the temperature actuator.

https://www.2carpros.com/articles/replace-blend-door-motor

and

https://www.2carpros.com/articles/car-heater-not-working

Here is what the job will be like for your car (Below) It is called a airmix servo motor. Also double check the operation of the heater valve.

Please let us know if you need anything else to get the problem fixed.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Thursday, November 16th, 2017 AT 4:23 PM
Tiny
RPM289
  • 1999 TOYOTA AVALON
  • 204,000 MILES

I have flushed the heater core, unhooked the water control valve and opened it manually but still no heat. I cannot move the cable from outside nor will it move with temperature control knob. I found a control unit in salvage yard no change. All buttons on both control units seem to move to correct positions but hot air. No idea what to try next.

Was this
answer
helpful?
Yes
No
Thursday, November 16th, 2017 AT 4:25 PM (Merged)
Tiny
MHPAUTOS
  • EXPERT
  • 31,766 POSTS

With the engine at operation temperature are both heater hoses hot to touch?

Was this
answer
helpful?
Yes
No
Thursday, November 16th, 2017 AT 4:25 PM (Merged)
Tiny
CSMOCK3
  • 1998 TOYOTA AVALON

Air Conditioning problem
1998 Toyota Avalon 6 cyl Front Wheel Drive Automatic 204000 miles

Question: 1998 Toyota Avalon v6 mileage: 120,000. Without warning, the air conditioner & fans quit working. This car has an outside air temp display & it suddenly does not show a temperature reading. I checked every fuse I could fine with a meter. All ok. The car starts & runs fine & all other electrical works ok, i.E, lights, rear defroster, windows, door locks, seats. It is equipped with an auto mode for the air with a temperature adjustment that will control the blower speeds. This is not working, or if you try to punch manual blower speeds, (each button will light up) but will not turn fan on, or if you push the ac button, will not work or light up. No engine service light either? Thanks!

Answer: Check wiring for damage or loose connections. Check ground connections

Was this
answer
helpful?
Yes
No
Thursday, November 16th, 2017 AT 4:25 PM (Merged)
Tiny
DOCFIXIT
  • EXPERT
  • 18,985 POSTS

Faulty A/C Amplifer left center of dash behind radio. May be able to get to it above gas pedal

Was this
answer
helpful?
Yes
No
Thursday, November 16th, 2017 AT 4:25 PM (Merged)

Please login or register to post a reply.

Recommended Guides