Engine shut off while running after adding HEET to the fuel it will not start

Tiny
ANONYMOUS
  • MEMBER
  • 1999 GMC YUKON
  • 200,000 MILES
Recently changed fuel pump and filter 3 months later car quit at intersection. I pushed it to lot and sat for a while. Then it started and was able to drive home 3-4 miles while noticing I am not getting much power or fuel to the engine. Did it a couple times. Added HEET to gas and now it wont start at all. No fuel making it to engine.
Saturday, October 27th, 2012 AT 3:52 PM

6 Replies

Tiny
JDL
  • EXPERT
Check for applicable trouble codes? When you first turn the key on, no crank, can you hear the pump run for a few seconds? If you can't hear it, check applicable fuses.
Was this
answer
helpful?
Yes
No
Saturday, October 27th, 2012 AT 4:18 PM
Tiny
JDL
  • EXPERT
I just wanted to add, if you have that spider fuel system, it is noted for problems.
Was this
answer
helpful?
Yes
No
Saturday, October 27th, 2012 AT 4:28 PM
Tiny
CHUCKLYNDE
  • MEMBER
Spider fuel system? That's a new one I haven't heard before.
Was this
answer
helpful?
Yes
No
Tuesday, April 14th, 2020 AT 7:42 PM
Tiny
DL AUTOSHOP
  • MEMBER
Hello, I'm Danny.

Yes, Its nickname is the "spider". It's the fuel injection control unit that is mounted in between the upper and lower intake manifold. You have to separate the intake manifold to gain access. I've attached a picture below and circled the "spider" in red. Hope this helps and thanks for using 2CarPros.
Was this
answer
helpful?
Yes
No
+1
Tuesday, April 14th, 2020 AT 11:27 PM
Tiny
CHUCKLYNDE
  • MEMBER
Thanks, Danny, I appreciate the answer and can see where the nickname came from. Always trying to increase my knowledge about these systems as I own 3 of them! Thanks again!
Was this
answer
helpful?
Yes
No
Wednesday, April 15th, 2020 AT 11:31 AM
Tiny
DL AUTOSHOP
  • MEMBER
Hello again.

Yes, they are prone to start causing problems around the 200,000 mile point usually with a misfire. They usually run $100.00 to $200.00 mark depending where you purchase. You're welcome for the info. I have a 1997 K1500 and my symptoms started showing at 250,000 miles along with transmission. Thanks again for using 2CarPros.

Danny-
Was this
answer
helpful?
Yes
No
Wednesday, April 15th, 2020 AT 12:10 PM

Please login or register to post a reply.

Sponsored links