Why does my car stall after running for 20 mins.

Tiny
IT'S MY CAR
  • 1999 FORD CROWN VICTORIA

I have a 99 Crown Vic that stalls after running for twenty minutes. Doesn't matter if it's idling or driving. I can start it back up only after it sits for 20 minutes or more. I have check and tested the fuel pump rely, fuses, battery, alternator, coolant temperature sensor and sending unit, fuel injectors and their connectors, coil connectors, and the coils which are new as are the spark plugs and boots. All have passed either a voltage test and/or an ohm test. The IAC valve is clean so is the MAF sensor. The exhaust sytem has been replaced front to back as has the DPFE sensor. The EGR valve passed its test and is clean. Now can someone lead me in the right direction as to what the problem may be.

I would like to add that the car starts up quick and easy when the engine is cold and idles beautifully. This problem did not start until my car ran completely out of gas one time. Did I possibly damage the fuel pump. I do have good fuel pressure before and after it stalls. There are also no SEC's stored and the car does not misfire or hesitate, it just shuts off. Holding my foot on the throtle does not help to keep it running either at that 20 min mark.

When I try to restart it the engine cranks fine but it acts like there is no spark. It wiil try to fire once or twice but sputters out even if I pat the gas peddle.

Do you
have the same problem?
Yes
No
Sunday, May 13th, 2012 AT 5:30 AM

6 Replies

Tiny
FIXITMR
  • MEMBER

You will have to check spark and fuel pressure to determine the problems origin.

Was this
answer
helpful?
Yes
No
Sunday, May 13th, 2012 AT 5:44 AM
Tiny
IT'S MY CAR
  • MEMBER

I have already stated that; "I do have good fuel pressure before and after it stalls" and "coil connectors, and the coils which are new as are the spark plugs and boots. All have passed either a voltage test and/or an ohm test."

I did not say I didn't have spark but that the car acts like it doesn't when trying to restart.

What else should I check and test as this is very frustrating. So please make sure you have read everything in my original post before answering.

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 4:55 AM
Tiny
FIXITMR
  • MEMBER

Have you checked for codes?

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 7:48 PM
Tiny
RASMATAZ
  • MEMBER

The fuel pressure might be good with key on engine off and running but when the fuel pump heats up it breaks open-running out of gas could have ruined the fuel pump-triple check

Was this
answer
helpful?
Yes
No
Monday, May 14th, 2012 AT 8:04 PM
Tiny
IT'S MY CAR
  • MEMBER

@ fixitmr - there are no CEL codes stored.

I still have not found the culprit of my problem but some thing has to be getting hot and causing the motor to shut down. I am going to replace the fuel pump and hope that solves the issue. If that doesn't then I will try replacing the ckp and cmp sensors. I haven't got a whole lot of money so I hope the first thing works.

Was this
answer
helpful?
Yes
No
Sunday, May 20th, 2012 AT 3:41 AM
Tiny
WGROOM2
  • MEMBER

Had same problem on 95 Tbird with 4.6 engine. Drove me nuts. Try this. Let engine run until it dies (20 mins) Disconnect wiring harness from MAF and leave it disconnected. See if engine starts. If so see if it goes beyond the dreaded 20 mins. If so it's a dirty or bad MAF. Tried cleaning mine with no luck. It was bad. Replaced it with one from junk yard and problem solved. Good luck. You can run without it connected but mixture will be off.

Was this
answer
helpful?
Yes
No
Saturday, June 2nd, 2012 AT 1:46 AM

Please login or register to post a reply.

Other Engine Stall Questions