WHY DON'T MY TAIL LIGHTS, SIGNAL LIGHTS, AND INTERIOR LIGHTS WORK?

  • Tiny
  • Ashleymccoy
  • 1999 BUICK PARK AVENUE
  • 187,000 MILES

The tail lights, left signal lights, and interior lights on my 1999 buick park avenue don't work. What may be the problem?

Do you
have the same problem?
Yes
No
Wednesday, October 3rd, 2012 AT 8:51 PM

5 Replies

  • Tiny
  • KHLow2008
  • EXPERT
  • 41,981 POSTS

Start by checking for blown fuses.

Was this
answer
helpful?
Yes
No
-1
Wednesday, October 3rd, 2012 AT 8:58 PM
  • Tiny
  • Ashleymccoy
  • MEMBER

I've checked the fuses. There fine.

Was this
answer
helpful?
Yes
No
+1
Wednesday, October 3rd, 2012 AT 9:12 PM
  • Tiny
  • KHLow2008
  • EXPERT
  • 41,981 POSTS

By interior lights do you mean the dash and other illuminations? Does it include the courtesy and dome lights?

For the left turn signals, do any of exterior bulbs lights up or none at all? Does turning on the hazard lights make them work?

For the fuses, apart from underhood there is one fuse block under the dash.

All these are linked to the Lamp Control Module, behind left side of dash, right of steering column.

Was this
answer
helpful?
Yes
No
Thursday, October 4th, 2012 AT 9:03 AM
  • Tiny
  • Ashleymccoy
  • MEMBER

The lights on the dash, like were the speed is don't work. My brake lights work and my right side turn signal and hazard lights work. But only the brake lights work on the left side. But the tail lights don't work period.

Was this
answer
helpful?
Yes
No
Sunday, October 7th, 2012 AT 3:38 PM
  • Tiny
  • KHLow2008
  • EXPERT
  • 41,981 POSTS

For the stop lights, check the bulb. Test for battery voltage to the Light Blue wire. This wire is linked to each othere between right and left.

Dash illuminations and taillights shares the same circuit and gets its power supply from the Lamp Control Module (LCM). Test the LCM Brown wire for battery voltage when taillights are turned on.

If all lights works correctly when hazard lights are turned on, the left not working could be due to a faulty turn signal switch.

Was this
answer
helpful?
Yes
No
+1
Sunday, October 7th, 2012 AT 5:43 PM

Please login or register to post a reply.

Other Running Light Not Working Questions