Fuel pump

Tiny
MIKYSPIKY
  • MEMBER
  • 1998 PLYMOUTH BREEZE
  • 156,000 MILES
Fuel pumps works when hooked up to a battery but when put in vehicle it wont ingauge
Do you
have the same problem?
Yes
No
Monday, March 19th, 2012 AT 4:24 AM

3 Replies

Tiny
CARADIODOC
  • EXPERT
It should only run for one second, then again during engine rotation, (cranking or running). Have you checked for spark?
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 4:48 AM
Tiny
MIKYSPIKY
  • MEMBER
Yes their is no spark but when u turn key on u should here it ingauge the pump and I dont hear it turn on
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 5:14 AM
Tiny
CARADIODOC
  • EXPERT
Well, you can work on the pump circuit all you want to but that won't fix the lack of spark. Listen under the tank when a helper turns the ignition switch to "run". You should hear the hum of the pump for one second and no more. If you don't, you have two different problems.

Check the diagnostic fault codes too. If you have one for the camshaft position sensor or the crankshaft position sensor, the Engine Computer won't turn on the automatic shutdown (ASD) relay during cranking. That will kill the power to the ignition coils, injectors, alternator field, oxygen sensor heaters, and fuel pump or pump relay.

If you have a code related to "can and crank sync", check the timing belt to see if it has jumped two teeth or more. If it has, the computer will shut the engine down to protect the valves.
Was this
answer
helpful?
Yes
No
Monday, March 19th, 2012 AT 5:33 AM

Please login or register to post a reply.

Sponsored links