Not getting signal to fuel pump

Tiny
MARKED0210
  • MEMBER
  • 1997 OLDSMOBILE BRAVADA
  • 180 MILES
My fuel pump recently stopped pumping, but I tested it and it works, the relay works because I manually tested it but there is no signal to it. I have already dropped the tank and battery tested the pump, checked every fuse, and changed the relay.
Do you
have the same problem?
Yes
No
Monday, September 5th, 2011 AT 3:16 PM

7 Replies

Tiny
RASMATAZ
  • MEMBER
Check the fuel pressure with a gauge if its within specs if okay-check the injector/s if its pulsing on a TBI-Spider type-remove upper plenum and look for fuel on the poppet valves. Could also be the computer controlled of the fuel pump relay circuit
Was this
answer
helpful?
Yes
No
Monday, September 5th, 2011 AT 3:38 PM
Tiny
JDL
  • EXPERT
How did you test the pump? A no load test isn't worth much. I've seen faulty pumps that would run fine on the work bench, but wouldn't make any pressure. Did you check for good voltage and ground at the pump motor?
Was this
answer
helpful?
Yes
No
Monday, September 5th, 2011 AT 3:39 PM
Tiny
JDL
  • EXPERT
There is a redundant power supply to the fuel pump from oil pressure switch. If the switch is functiuonal and has voltage, the pump will run, regardless of relay.
Was this
answer
helpful?
Yes
No
Monday, September 5th, 2011 AT 3:50 PM
Tiny
RASMATAZ
  • MEMBER
JDL-Affrimative on the fuel pump and oil pressure sending unit it powers the pump when the engine fires up-the relay is only good for the 2secs effect
Was this
answer
helpful?
Yes
No
Monday, September 5th, 2011 AT 4:09 PM
Tiny
MARKED0210
  • MEMBER
Thank you all for your great advice guys, but I had a spare PCM in the garage and I switched it out and lo and behold everything came back to life! Unfortunately now the PCM has to be brought to the dealer to be flashed or reprogrammed as it runs terrible. If you have any advice on that subject my ears are wide open!
Was this
answer
helpful?
Yes
No
Tuesday, September 6th, 2011 AT 4:19 AM
Tiny
RASMATAZ
  • MEMBER
It probably has to relearn the idle speed thru the IACV
Was this
answer
helpful?
Yes
No
Tuesday, September 6th, 2011 AT 5:20 AM
Tiny
REPETE1121
  • MEMBER
I have a 1996 olds 88 the fuel pump stoped working because the ground terminal junction point was oxidized. The junction for the black wire grounds is located under the carpet and pad below the emergency brake release pedal. All the terminals were replaced with ring terminals and bolted together.
Was this
answer
helpful?
Yes
No
Tuesday, September 27th, 2011 AT 3:18 AM

Please login or register to post a reply.

Recommended Guides