1996 GMC Jimmy engine shut down

Tiny
JDDINGO
  • MEMBER
  • 1996 GMC JIMMY
  • 120,000 MILES
On freeway engine quit running, would not restart. On searching for cause:
engine will start and run momentarily with either--fuel pressure at shrader valve with ign on.11lbs but does not hold pressure even with ign still on--while cranking 10/11lbs, but will not start. Fuel pump seems to run a couple of seconds when
first turning on ign. 4.3 vortech 1996 jimmy 4wd/automatic, throttle body.
oil pressure 60lb@1500rpm, 1/2 tank of gass, no earlier symptoms noticed.
must do my own repairs and on fixed income. Please help. Stranded until reparied
thank you so much, Jim Delk
Do you
have the same problem?
Yes
No
Tuesday, September 10th, 2013 AT 11:19 PM

13 Replies

Tiny
HMAC300
  • EXPERT
If this is a cpi and I think it is it should be 60-66 psi not 11 if it is tbi it should be 9-11 psi and should hold if not the regulator may be bad.
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 6:28 AM
Tiny
JDDINGO
  • MEMBER
Hmac300,
first, I want to give a special thanks to you for quick response. I need help for sure on this one. If you are correct.I'll be dancing all week. For sure it is throttle body injection.I don't know too much on how the injectors are controlled, but it seems pressure is the ghost. I will get after the regulator after I find it and how to test it, if you have any suggestions on that point please let me know. Any way,
no matter what I will send a donation on the 4th or5th of oct, after my ss comes in.
Finding a helping hand today is real challange for old guys like me. Thanks again.
Jim delk, jddingo

wondering if the pressure reads 10-12 while cranking and the injectors are
functioning, should'nt it fire? Any way pressure is a problem and suspect.
I'll get back to you. Thanks again.
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 7:55 AM
Tiny
HMAC300
  • EXPERT
Look on your 8 th digit on your vin plate it should have a w or x and that is the engine code which would stand for csi type of engine. It should have 60-66psi of fuel pressure at engine. Not11 or 12. If this is a tbi unit on this truck then it has been changed and is not correct.
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 9:25 AM
Tiny
JDDINGO
  • MEMBER
I am not near the car until afternoon. I will get back to you. I can say that I purchased a fuel pump in november of last year from outlet4usa automotive, item#280749488857 for $68.99. That pump is for blazer s10/t10gmc jimmy oldsmobile bravada 1996 e3925m. Has been running fine until shut down.
You may be correct. If the pump info tells you something please let me know as that would be almost a certanity the pump is bad. If those cars the pump fits
are using 60-66psi then mine does too. Thank you again
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 10:00 AM
Tiny
HMAC300
  • EXPERT
I don't know what your financial situation is but try to get an ac delco pump not airtex or ANYTHING made in china they omit parts and do sloppy work so they don't last. This includes light bulbs, buy brand name, even if they are made in Mexico they are made to the brand spec like Sylvania etc
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 10:06 AM
Tiny
JDDINGO
  • MEMBER
Hmac300
I know, especially a hard to replace gismo of any kind. Good advise. Truth is I do pick and choose carefully but this time I just gambled. The vin # is below and the 8th is the letter w. So what is the sure way to tell which system. I was relying on info that suggested I had a csefi, central sequential electronic fuel injection - system
which called for 9-13 ign on/3-10 running. How do I id the system? That was based
on the year and make but as you question it could have been changed.
Thanks for your help. What can I examine to show what system I have?
Jddingo

1gkdt13w4t2552970
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 1:51 PM
Tiny
JDDINGO
  • MEMBER
Hmac300

You must be right. I finally got the info on the pump from 4usa auto parts.
The pump they sold me is 60psi over 50psi max/min flow. I am planning to check the pressure on the inlet side of the fuel filter and if it reads 10-15 or low psi I will put in a new fuel pump. Do I need to test or check the fuel regulator and how do I do that?
Thank you again for your help. Had you not told me something is doubful on the fuel pump psi who knows what I may have mistakenly taken apart. Just so you
know. Thank you jddingo
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 2:49 PM
Tiny
HMAC300
  • EXPERT
Check at engine not fuel filter
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 3:05 PM
Tiny
JDDINGO
  • MEMBER
At the schrader valve next to the fuel line at the intake manifold the pressure is 10-11 with ign on but hold for only two seconds the goes to zero.
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 3:09 PM
Tiny
HMAC300
  • EXPERT
The n replace pump and filter
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 3:17 PM
Tiny
JDDINGO
  • MEMBER
I will do that. Thank you again. I willalso send a donation on the 4th or 5th of oct
and I will let you know that is done. I will also keep you posted on outcome.
Thanks again. Jddingo
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 5:56 PM
Tiny
JDDINGO
  • MEMBER
Hmac300,

My son replaced the fuel pump yesterday. 50-60 psi at the schrader and holds.
Engine runs smoother and pep is better. So pleased. Do have a question. On
removal the pump had dropped the expandable tube from the top where it connects
to the connector lid. The metal crimp and tube had just fallen off. Or could it have been pushed off for some othe reason. It was a cheap pump and you have cautioned about that. So the supposed question is, did the tube pop off because of crappy assembly or could have a defect else where caused the hose to pop off.

While your help may have been simple in nature you can bet it was a very revealing
exchange for me. Can't get over the book being so explicit and so wrong. Any way I thank you very much again. I will follow up the first of the month with a donation and let you know. Thanks again. Jddingo
Was this
answer
helpful?
Yes
No
Tuesday, September 17th, 2013 AT 9:06 AM
Tiny
HMAC300
  • EXPERT
I'd say crappy assembly for the tube falling off. Glad it 's fixed now.
Was this
answer
helpful?
Yes
No
Tuesday, September 17th, 2013 AT 12:04 PM

Please login or register to post a reply.

Recommended Guides