1995 Camaro problem

Tiny
XAVANUATU
  • MEMBER
  • 1995 CHEVROLET CAMARO
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 50,000 MILES
Hi, I changed my IDLE following some high RPM probleme but know the car start and can run when cold but if I try to restart when it's hot it will only stay on if I play on acceleration and impossible to stabised the RPM and die.
Do you
have the same problem?
Yes
No
Tuesday, August 16th, 2011 AT 3:57 AM

24 Replies

Tiny
DOCFIXIT
  • EXPERT
What was done to"changed my idle"?
Was this
answer
helpful?
Yes
No
Tuesday, August 16th, 2011 AT 12:54 PM
Tiny
XAVANUATU
  • MEMBER
Idle air control valve
Was this
answer
helpful?
Yes
No
Tuesday, August 16th, 2011 AT 8:28 PM
Tiny
DOCFIXIT
  • EXPERT
O.K. Suspect EGR remove clean pintel and passagewats check to see if pintel stuck
Was this
answer
helpful?
Yes
No
Tuesday, August 16th, 2011 AT 8:35 PM
Tiny
XAVANUATU
  • MEMBER
Before to try I would like a confirmation on the piece I need to clean, If you wish check the photo it would help. As you can see it's in bad shape
Was this
answer
helpful?
Yes
No
Tuesday, August 16th, 2011 AT 10:16 PM
Tiny
DOCFIXIT
  • EXPERT
That's the puppy
Was this
answer
helpful?
Yes
No
Wednesday, August 17th, 2011 AT 1:19 PM
Tiny
XAVANUATU
  • MEMBER
The EGR is perfectly intact of carbon, so look like the passagewats. I thinking when I removed the air control valve it was full of carbon; could it be the carbon of air control valve who block a passage or not?
Was this
answer
helpful?
Yes
No
Thursday, August 18th, 2011 AT 3:28 AM
Tiny
DOCFIXIT
  • EXPERT
Yes any carbon not good is check engine light comming on?
Was this
answer
helpful?
Yes
No
Thursday, August 18th, 2011 AT 1:45 PM
Tiny
XAVANUATU
  • MEMBER
Yes the check engine is on most off the time and off sometimes.
Was this
answer
helpful?
Yes
No
Thursday, August 18th, 2011 AT 8:30 PM
Tiny
DOCFIXIT
  • EXPERT
When light is on and have time go to AutoZone and have code read then post
Was this
answer
helpful?
Yes
No
Thursday, August 18th, 2011 AT 9:06 PM
Tiny
XAVANUATU
  • MEMBER
Ok, gonna try to find the code this afternoon, there is maybe one computer who could read it on my island.( The beauty of living on small pacific island)
Was this
answer
helpful?
Yes
No
Thursday, August 18th, 2011 AT 10:26 PM
Tiny
DOCFIXIT
  • EXPERT
Not on Guam are you?
Was this
answer
helpful?
Yes
No
Friday, August 19th, 2011 AT 9:05 PM
Tiny
XAVANUATU
  • MEMBER
No, I'm on Vanuatu (South West Pacific) and there is no other camaro in the country. For the code the first attempt failed (no adaptor). Hope my friend gonna find the adaptor this week.
Was this
answer
helpful?
Yes
No
Sunday, August 21st, 2011 AT 8:53 PM
Tiny
DOCFIXIT
  • EXPERT
Could remove EGR and make a plate and block it off
Was this
answer
helpful?
Yes
No
Monday, August 22nd, 2011 AT 3:30 PM
Tiny
XAVANUATU
  • MEMBER
EGR removed, pb still but coming better. Do the PCM need time to adjust
Was this
answer
helpful?
Yes
No
Wednesday, August 24th, 2011 AT 8:38 PM
Tiny
DOCFIXIT
  • EXPERT
Possible get fuel pressure checked?
Was this
answer
helpful?
Yes
No
Wednesday, August 24th, 2011 AT 8:45 PM
Tiny
XAVANUATU
  • MEMBER
I made check the fuel pump on friday, they told me it was ok. This week-end I change the fuel filter, and check what could be bad on the fuel line. Fisrt thing I found was a lost wire on a sensor on the right of admission pipe (reconnected), I found also a pipe from the fuel line disconnected ( reconnected, well done for the garage who test the pump and didn't see it) I found a bucket behind the left rear whell with line to go to the fuel tank but not connected ( not reconnected yet). After this the car start good with normal rpm when cold, run good without check engine. On hot restart the engine go to 3000 rpm without check engine light off. I joint the photo of the differents elements for your understanding because I don't know the english name.
Was this
answer
helpful?
Yes
No
Sunday, August 28th, 2011 AT 10:28 PM
Tiny
DOCFIXIT
  • EXPERT
In last PIC the hose going to black right angle thing is PCV remove shake it should rattle, spring and plunger. The can thing is part of EVAP and hose needs to be hooked up. Other sensor looks like MAP that could effect idle. Is there a Vacuum hose to it?
Was this
answer
helpful?
Yes
No
Monday, August 29th, 2011 AT 1:04 PM
Tiny
XAVANUATU
  • MEMBER
Ok for PVC pipe and Evap, The sensor is MAP and there is a hose connect to it.
Was this
answer
helpful?
Yes
No
Monday, August 29th, 2011 AT 8:54 PM
Tiny
DOCFIXIT
  • EXPERT
Is there vacuum on MAP hose? If yes disconnect what happens?
Was this
answer
helpful?
Yes
No
Tuesday, August 30th, 2011 AT 2:36 PM
Tiny
XAVANUATU
  • MEMBER
When high RPM hose disconnetion make RPM back to 1000 but with strong fuel smell.
Was this
answer
helpful?
Yes
No
Tuesday, August 30th, 2011 AT 8:37 PM

Please login or register to post a reply.

Recommended Guides