Automatic transmission shifting issue

Tiny
SWEETCALI
  • MEMBER
  • 1994 MAZDA B4000
  • 205,000 MILES
I have a 94 Mazda B4000 4L 4x4, it was running fine until last night when I was driving along and it droped a gear, hard, and didn't want to shift back up. Now when driving it will red line itself before it will shift, and to get it to shift I have to get up to speed, let off the throttle and it may shift and if it doesn't I have to give it some throttle and lay off again and it'll usually go into gear, sometimes hard. I'm not missing any of the gears, my tranny fluid is full, and besides the shifting issue the tranny seems to be working fine. So I'm thinking it may be some sort of sensor.

Also, as long as I am just putting around it doesn't seem to have the problem as bad. Putting around means just barely on the throttle with little to no acceleration, under 30-40 kph, 10-15mph.

Thanks
Do you
have the same problem?
Yes
No
Saturday, February 18th, 2012 AT 5:53 PM

2 Replies

Tiny
KEN
  • ADMIN
Hello,

This sounds like you have a catalytic converter that is getting plugged lowering he vacuum in the engine causing the transmission to shift late. Here is a guide to confirm the issue.

https://www.2carpros.com/articles/how-to-test-a-catalytic-converter

and if bad

https://www.2carpros.com/articles/catalytic-converter-replacement

Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Saturday, February 18th, 2012 AT 5:58 PM
Tiny
SWEETCALI
  • MEMBER
You guys are great! I had the cat converter replaced and bam! All fixed thanks again. I love this site.
Was this
answer
helpful?
Yes
No
Sunday, March 18th, 2012 AT 5:08 PM

Please login or register to post a reply.

Recommended Guides