S-10 Has flatspot when secondaries open, bogs down a little bit on hills

Tiny
IRONTIRES
  • MEMBER
  • 1983 CHEVROLET S-10
  • 234,000 MILES
Im having issues with my 1983 2.8L, when you floor it, there's a flat-spot where the engine isn't running for like 3 seconds, then it picks up, still has doesn't have the power it should have, bogs down a bit

replaced most of the replaceable stuff

new fuel pump, filters, plugs, wires, distributor parts, checked EGR, clean oil, clean gas, new vacuum hoses, no leaks anywhere, replaced the coil, catalytic converter not plugged.

there is no computer in it, so there's no 02 sensors or anything.

Do you
have the same problem?
Yes
No
Wednesday, May 2nd, 2012 AT 10:14 PM

32 Replies

Tiny
FIXITMR
  • MEMBER
Is that a carburetor?
Was this
answer
helpful?
Yes
No
+1
Wednesday, May 2nd, 2012 AT 10:31 PM
Tiny
IRONTIRES
  • MEMBER
Yes sorry, new Holly II carb 2BBL
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 10:40 PM
Tiny
FIXITMR
  • MEMBER
Vacuum or electronic advance?
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 10:43 PM
Tiny
IRONTIRES
  • MEMBER
Vacuum
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 10:43 PM
Tiny
FIXITMR
  • MEMBER
Vacuum or mechanical secondary?
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 10:47 PM
Tiny
IRONTIRES
  • MEMBER
Vacuum I believe
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 10:50 PM
Tiny
FIXITMR
  • MEMBER
Does it do it in neutral or just under load?
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 11:10 PM
Tiny
IRONTIRES
  • MEMBER
Both
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 11:13 PM
Tiny
FIXITMR
  • MEMBER
Did problem start with new carb?
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 11:13 PM
Tiny
IRONTIRES
  • MEMBER
Yes, about a year after
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 11:15 PM
Tiny
FIXITMR
  • MEMBER
Is carb accellerator pump working ok? Does it have an enrichment circuit?
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 11:17 PM
Tiny
FIXITMR
  • MEMBER
Is your timing advancing ok? Is it vacuum advance or retard?
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 11:18 PM
Tiny
IRONTIRES
  • MEMBER
I have to pump the gas about 20-25 times before it will start at first, and the timing was spot on last time I checked
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 11:25 PM
Tiny
ASEMASTER6371
  • EXPERT
The carb is definitely your issue. You need to check the power valve which is a very common failure on holleys.

Roy
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 11:42 PM
Tiny
FIXITMR
  • MEMBER
Is choke auto or manual?
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 11:43 PM
Tiny
FIXITMR
  • MEMBER
Power valve is the enrichment I mentioned. Starting issue sounds like choke related as long a fuel level in bowls is fine.
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 11:44 PM
Tiny
IRONTIRES
  • MEMBER
Its supposed to be a automatic choke, but I have to manually set it and move it around to either choke it, or allow the secondaries to open, wheres the power valve?
Was this
answer
helpful?
Yes
No
Wednesday, May 2nd, 2012 AT 11:45 PM
Tiny
IRONTIRES
  • MEMBER
And how would I check it/fix it
Was this
answer
helpful?
Yes
No
Thursday, May 3rd, 2012 AT 12:01 AM
Tiny
FIXITMR
  • MEMBER
Is choke electric? Was carb BRAND new and did choke work for a while?
Was this
answer
helpful?
Yes
No
Thursday, May 3rd, 2012 AT 12:05 AM
Tiny
IRONTIRES
  • MEMBER
I dont think the automatic choke ever worked, I think it was a reman carb from kragen (o'rileys
Was this
answer
helpful?
Yes
No
Thursday, May 3rd, 2012 AT 12:15 AM

Please login or register to post a reply.

Recommended Guides