Mechanics

BLOWER HEAT/A/C FAN DON'T WORK

2006 GMC Sierra

Heater problem
2006 GMC Sierra V8 Four Wheel Drive Automatic 67,000 miles

I like to know what the problem may be.I turn the fan switch from low to high and nothing is happening, nothing blowing out the vents, I have no heat ac or defrost. Usually you can hear the fan motor going when on but there is no noise, nothing, have checked all fuses and they are ok. Just wondering if it could be the resister or the blower motor.I haven't checked to see if there is power to the resister or motor, the fan just stopped working no warning or any type of noise just quit, may be the switch, hoping someone could guide me in the right direction before I start taking things apart
your help would be appreicated
thank you
Gary
AD
Avatar
Enjoy425
May 20, 2010.




Hi enjoy425, Welcome to 2carpros and TY for the donation

Power the blower motor direct from the battery if it comes on check and test the blower motor resistor and blower switch both checked out get the HVAC control module

Rasmataz
May 20, 2010.
I check the blower motor to the battery it works fine just not sure how you check the resistor relay, I see the resistor harness the black wire is melted.I used a tester light on the relay harness I only had two live wires with the key on, should I have more then just two live
thanks Gary

Tiny
Enjoy425
May 21, 2010.
It depends on the position of the blower switch such as low,med, high. The red wire shhould have constant power


http://www.2carpros.com/forum/automotive_pictures/12900_blower_21.jpg

AD

Rasmataz
May 21, 2010.
I cheched the fan motor to the battery works fine and looked at the resistor and seen that the black ground wire was melted at the end and 5 of the 7 wires didn't have power so each wire would be for the 5 speeds on the fan, the only wire I got live was the red that is always live. So I bought a new resistor and put it in and checked each wire to the speed example to switch to number 1 got power turn switch to #2 got power and so on got power to to each speed I put it on. It work fine for a couple of days and know today monday the fan has stopped working and I can smell burnt wires, can you tell me the problem, thanks
Gary

Tiny
Enjoy425
May 24, 2010.

AD