Does not start, installed a new ignition in and it still does not work?

Tiny
MYVANS
  • MEMBER
  • 2000 CHEVROLET ASTRO
  • V6
  • 2WD
  • AUTOMATIC
  • 146,000 MILES
Someone tried to steal my van so I installed a push button to start the van because the ignition was broken I put a push button and the van started with no problem. Then my starter went out, so I replaced it. The van wouldn't start so I replaced the alternator, it still wouldn't start. So, I had a mechanic look at the van and he said that the push button wouldn't work. So, I put a new ignition in and it still didn't work. Then he said I needed an ECU. So, I replaced that but it still didn't work and in the end he said he couldn't fix the van. The van started when I put the push button on so I'm not sure why it won't start now. The van has a full tank of gas. When I try to start the van sometimes I hear the fuel pump on sometimes I don't what could be the reason why it wont start.
Do you
have the same problem?
Yes
No
Sunday, July 31st, 2022 AT 9:20 PM

1 Reply

Tiny
KEN L
  • ADMIN
When you try to start the car does the security light flash? If so, this is the problem, here is a guide to help you reset the system. If this doesn't work you can try a hard reboot which is done by removing the negative side of the battery, with the cable loose from the negative side of the battery, hold it to the positive terminal for 1 minute this will discharge the memory capacitors in the BCM and PCM allowing the system to reboot.

https://www.2carpros.com/articles/how-to-reset-a-security-system

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
Monday, August 1st, 2022 AT 12:36 PM

Please login or register to post a reply.

Sponsored links