Turn signals and beam stopped working

Tiny
HAROLD.BUNGER
  • 2000 VOLVO S80

Electrical problem 6 cyl Two Wheel Drive Automatic 60000 miles

Turn signals and Hi beam stopped working at the same time. All plastic fuses are good.

Do you
have the same problem?
Yes
No
Thursday, March 11th, 2010 AT 8:19 AM

5 Replies

Tiny
JIS001
  • EXPERT
  • 2,339 POSTS

Where did you check fuses at? The engine compartment or inside the car?

Was this
answer
helpful?
Yes
No
Sunday, March 14th, 2010 AT 6:38 PM
Tiny
HBUNGER
  • MEMBER

I found the answer. Pull out the # 21, 22 and 23 fuses from the fuse box inside the passenger compartment. Turn the key until the accessories come on. There is no need to start the car, you just want the electronics to come on. Wait about 5 seconds. Turn the key off. Put the fuses back in and the problem is solved.
If someone tells you that you have to disconnect the battery, it is not necessary. Turning the key drains the capacators. That resets the malfunctioning modules.

Was this
answer
helpful?
Yes
No
-1
Sunday, March 14th, 2010 AT 7:42 PM
Tiny
JGLECHTER
  • MEMBER

Just wanted to let you know I just had the same problem and I fix it in 5 minutes. Thanks for the assistance.

Was this
answer
helpful?
Yes
No
Saturday, April 14th, 2012 AT 12:05 AM
Tiny
JP RYDING
  • MEMBER

I registered just to say that the fuse pull fix worked for me just now. Was about 50ks from home so would have had a real issue. Thanks Hbunger!

Was this
answer
helpful?
Yes
No
Tuesday, May 30th, 2017 AT 8:40 AM
Tiny
2CARPROS KEN
  • ADMIN
  • 7,824 POSTS

Glad you could get it fixed, that kind of problem can be tough. Please use 2CarPros anytime we are here to help

Cheers, Ken

Was this
answer
helpful?
Yes
No
Thursday, June 1st, 2017 AT 11:58 AM

Please login or register to post a reply.

Related Turn Signal Not Working Questions

Recommended articles