ENGINE LIGHT ON AND BATTERY DEAD

2000 Vauxhall Corsa

Tiny

dino_fultona

April, 4, 2009 AT 12:06 PM

Electrical problem
2000 Vauxhall Corsa Two Wheel Drive Manual 54000 miles

Hi Car Repair I was hoping you could help me, my vreg 1.0 corsa has been running funny for a while now, loosing power mid acceleration and hunting when pulling away. I had the spark plugs replaced a couple of months ago with no change. The engine light has now started to stay on and the battery has completely died with no response after turning the ignition. I've taken the battery out the car to try and charge it up, is this ok? What could be causing the problem? Was going to get it put on the diagnostic machine when the battery died so I need to try sort that first. The cost of repair is looming in my mind, but I really want it running again as its a good car usually. Hope you can help me, Thanks.

FOUND 17085 RELATED QUESTIONS

5 Answers

Tiny

Dave H

April, 5, 2009 AT 7:23 AM

Recharge the battery or replace with new .. install battery on car and reset the immoboliser .. by locking and unlocking the doors ... have the vehicle plugged into a diagnostic computer to find out why the MIL is coming on and repost with the full fault codes for a better diagnosis and repair information !


http://www.2carpros.com/forum/automotive_pictures/266999_AAA2_435.png

Tiny

dino_fultona

April, 6, 2009 AT 3:02 PM

I've put the battery back in and its supplying all the power and has managed to start the car eventually however the alternator light is staying on constantly and the MIL light, could there also be a problem with the alternator? Noticed a strong burning smell while engine was running. I'm phoning to book it in to the garage tomorrow.

Tiny

Dave H

April, 6, 2009 AT 7:27 PM

The alternator will need replacing ... this was probably the fault all along .. have the alternator replaced and have the vehcle plugged into a diagnostic computer to verify why the MIL is on .. I think this will just be from a power loss to a sensor !!

let me know


http://www.2carpros.com/forum/automotive_pictures/266999_AAA2_449.png

Tiny

dino_fultona

April, 8, 2009 AT 9:58 AM

Garage said its needs a new alternator like you said and a EGR valve? I've been quoted 460 for the parts and labour, thats also including being put on the diagnostic machine.

Tiny

Dave H

April, 8, 2009 AT 10:12 AM

The EGR valve fault may just be showing because of a low voltage supply caused by the alternator malfunction ... I would have them repair the alternator and clear the codes from the cars computer and then see if the EGR fault code returns .. ?

hope this helps .. let me know


http://www.2carpros.com/forum/automotive_pictures/266999_AAA2_473.png

Please login or register to post a reply.

Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear Mercedes Benz
Code Read Retrieval/Clear Mercedes-Benz C230
How to gather codes Ford Explorer
Code Read Retrieval/Clear - Dodge Stratus