Corsa b 1.2 will lose power when going uphill and check engine light comes on

Tiny
DANIEL STRAWBRIDGE
  • MEMBER
  • 2000 VAUXHALL CORSA
  • 1.2L
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 75,000 MILES
My vehicle is having an issue there are two things happening, but I get the feeling its the same thing causing both problems. First is when starting the car it starts the first time every time with no problems and idles fine but sometimes (not every time) when I pull away it will pull away and then the car will just stop moving. If I put the clutch down and try pulling away again it pulls away to about 5-10 mph and wont go anywhere unless I repeat, but after doing this a few times she (wakes up) and is suddenly fine. The second problem is when driving uphill at speed (it does not seem to happen when going slowly in a low gear) only if I am in for example 3rd gear going 40 mph I can feel the engine losing power and acceleration then the check engine light will illuminate the car will continue up the hill but will slowly (depending on the length and steepness of the hill) decelerate on some longer hills I have started in forth gear doing 60 mph and by the top I have had to change down to second and an now going 20 mph with my foot planted all the way up. Then at the top of the hill once it goes flat(er) the car will go back to normal and start accelerating okay and then the light will turn off and will have no issues until the next uphill. I hope you can think of what is causing this issue it maybe worth noting as well when going up the hill with engine light on if I release from the accelerator when its about half way the car seems to gain a little speed for a second, but only at a specific point when releasing the throttle it does not work when pressing it. Many thanks.

Dan
Do you
have the same problem?
Yes
No
Friday, May 13th, 2016 AT 7:46 AM

5 Replies

Tiny
HMAC300
  • EXPERT
We have no information on this car as it is not sold in USA scan for codes and check fuel pressure with a gauge. In US auto parts stores rent gauge not sure about other countries.
Was this
answer
helpful?
Yes
No
Friday, May 13th, 2016 AT 9:41 AM
Tiny
KEN
  • ADMIN
Hey Dan,

It sounds like to me like the clutch is slipping, when the car loses speed does the engine rev up? If so then the clutch disc has worn out, if not, have you changes the spark plugs because you are at the perfect mileage to need plugs? Here is a guide.

https://youtu.be/1xjAY0Kwa_Q

Check it out and get back yo us

Best, Ken
Was this
answer
helpful?
Yes
No
+1
Friday, May 13th, 2016 AT 3:57 PM
Tiny
DANIEL STRAWBRIDGE
  • MEMBER
Okay update.I got im my car this morning it done the typical kangarooing along the road between 0-5 mph but I noticed this time when the clutch was engaged or on the bite point the revs would drop considerably forcing me to press the clutch as to not stall the car I have ordered a new spark plugs and a new air, oil and fuel filter since there cheap in the hopes it sorts something out
Was this
answer
helpful?
Yes
No
Tuesday, May 31st, 2016 AT 11:25 AM
Tiny
HMAC300
  • EXPERT
Did you ever do what was said in first reply? Do that first to see if something else with computer sensors or fuel pressure is amiss
Was this
answer
helpful?
Yes
No
Tuesday, May 31st, 2016 AT 11:57 AM
Tiny
KEN
  • ADMIN
I have seen where the air intake boot in fail causing a an opening when which allows un metered air to enter the intake when the engine torques to one side which will cause the engine to jump ad low speeds can you check it and get back to us?
Was this
answer
helpful?
Yes
No
Tuesday, May 31st, 2016 AT 1:35 PM

Please login or register to post a reply.

Recommended Guides