Turn signals stopped working

Tiny
BEESTUH101
  • MEMBER
  • 1997 MERCURY MOUNTAINEER
  • 5.0L
  • V8
  • 2WD
  • AUTOMATIC
  • 300,000 MILES
Now my blinkers nor hazards won't work, neither the lights or the arrows on the dash. How do I go about diagnosing this problem? And what diagnosis instruments and/or replacement parts do I need?
Do you
have the same problem?
Yes
No
Saturday, January 19th, 2019 AT 11:20 PM

1 Reply

Tiny
HEYMAN1104
  • EXPERT
Personally, I'd bet on a failed turn signal and hazard flasher, which is located under the steering column, somewhere. I've located an image from Ford on AllData, but it's about as clear as mud. I've attached the image below. If this was your point of view, the front of the vehicle would be towards your left, and you'd be standing outside of the truck, just in front of the driver's door.

Unfortunately, I can't locate a step-by-step from Ford on how to get to it.

But you might want to check the fuses first. It's easy and free to do. Look at the second, third, fourth, and fifth images below for guidance on which ones to look at. Here's out step-by-step on checking fuses, in general: https://www.2carpros.com/articles/how-to-check-a-car-fuse

Also, I've attached an image showing a blown mini-fuse and a good mini-fuse, which are pretty standard in most American cars.

Good luck and keep us posted. Hopefully this gets it knocked out for you.
Was this
answer
helpful?
Yes
No
+1
Sunday, January 20th, 2019 AT 7:51 AM

Please login or register to post a reply.

Recommended Guides