Engine shake problem

Tiny
AL87
  • MEMBER
  • 2007 TOYOTA YARIS
Four cylinder front wheel drive automatic 77,000 miles.

Hello Everyone,

I have had the car for three years now and it has been great until about two months ago when completely out of the blue not to mention in the middle of the city the engine would start shaking and would only make it to about twenty km/h and go no faster then that only after about ten or so seconds (sometimes even longer) the engine would all of a sudden kick in however, on occasion the engine would not even kick in only after I pulled over and turned it off for a few minutes it be okay for a little while until it happens again.

Most of the time this would happen:
- I start up the car drive down the freeway for about little while at about 90-100KM/h
- When I stop at the next traffic lights the car would slowly start shaking until it starts really chugging (however the engine would never die which is the weird part).

On occasion this would happen:
- Same as before I drive at about 90-100KM/h on the freeway for a while.
- Then all of a sudden the car would gradually slow down and even though I got my foot on the gas it does not accelerate
- Then on the next traffic light stop it would only accelerate to about 20-40KM/h and would not go any more faster after about ten seconds in when the engine kicks in (if lucky).

However, it is much more frequent now and almost got me killed when the engine eventually shut off in the middle of a really busy road, tell you what it is not pretty looking at a truck screeching toward you at 90KM/h.

I have had it to and from Toyota more times then I can count and it is frustrating beyond all comprehension they have not fixed this. I am extremely desperate since I really badly need my car since it is my only means to get to and from Uni.

I hope someone can help identify this problem. Thank you very much in advance for any advice what so ever.
Do you
have the same problem?
Yes
No
Friday, May 21st, 2010 AT 2:41 PM

11 Replies

Tiny
MJOHNNZ
  • MEMBER
Hi,

I have got the same car that you got and it is also doing the shaking. It has not done it while driving though, but it always does it while on neutral and parked. It has been in and out of Toyota but has not been fixed as well. It has got a three year guarantee that has not run out yet and I am planning on pushing this a step forward if they are not able to fix this soon.

How is your problem? Has it been solved?

Cheers!
John
Was this
answer
helpful?
Yes
No
+3
Monday, August 23rd, 2010 AT 11:00 PM
Tiny
GABRIELVINCE
  • MEMBER
I have the same problem with Al87. I send it to Toyota to fix the problem they just clean the fuel injector. And the shaking was gone.

But after two months the same problem occurs again but it is not shaking but it ran around twenty to forty mph no more increase on its speed. When I slowly pump few times on the accelerator it comes back again in normal condition.

Can any one tell us how to resolve this problem?
Was this
answer
helpful?
Yes
No
+6
Tuesday, September 28th, 2010 AT 7:19 AM
Tiny
SHARK
  • MEMBER
I also have the same problem as Al87. Took it to Toyota, they took my money and did not fix it.
Was this
answer
helpful?
Yes
No
+1
Friday, May 20th, 2011 AT 11:54 PM
Tiny
SHARK
  • MEMBER
Hi AL87, did you find out what the problem was? My car is doing the exact same thing and I have taken it to Toyota more than once. They simply could not fix it after cleaning my wallet out.

Just wondering if you could give me a hand figuring out what the problem is with my car. I have a 2007 model Toyota Yaris 1.5 liter automatic. Recently the car has developed a problem where if you drive it for roughly ten minutes and then come to a stop, it violently shakes, loses all power and wants to stall. If I turn the car off and then on again it goes back to normal. Drive it around the block again and it does the same thing. I have taken it to a private mechanic who charged me $400.00 to change fuel filter, clean out the fuel tank and replace injectors with other ones with no result, it still shook when I got it back. Then I decided to take it to Toyota and when they plugged up the diagnostics computer it showed a fault with the air flow sensor. They cleaned it and it was okay for maybe two weeks but then started doing it again but was worse. I took it back, left it there for a week and they found that bank 1 was too rich, air flow sensor circuit low, intake air temp circuit high input, throttle pedal position sensor switch "d" and"e" voltage correction and then they said it was a fuel related problem but could not fix it! They charged me another $242.00 for doing nothing. The car is now at home in the driveway still not working.
I decided to look at it myself as I have a few years experience working on cars. Checked injector pulse and all four were good, checked spark plugs, all clean, cleaned throttle body and air flow meter as well. Took the car around the block to warm it up and then waited for it to start shaking. When it did start to shake I disconnected one of the plugs going to one of the coils to the spark plug and the car seemed to idle better, not sure why. If you could help me figure out what could be the problem I would really appreciate it,

Thanks, Bill from Australia.
Was this
answer
helpful?
Yes
No
+4
Saturday, May 21st, 2011 AT 12:01 AM
Tiny
KEN
  • ADMIN
Hey guys, this is a problem with the spark plugs, because they are titanium it is tough to tell if they are worn out by looking at them you must replace them.

Please let me know what happens so it will help others.

Best, Ken
Was this
answer
helpful?
Yes
No
+1
Tuesday, January 17th, 2017 AT 11:50 PM
Tiny
EMINADO
  • MEMBER
Hey, My car is a 2008 Toyota Yaris. I am experiencing the same problem, it vibrates and goes off whenever I am in traffic or I slow down. I restart the car try accelerating it is a bit slow until it finally picks. Now the car is just going off in the middle of the road. I have changed my plugs changed one nozzle, serviced the injector, still not working. The mechanic said it is an electrical fault. Is this a problem with all Toyota Yaris? I am tired.
Was this
answer
helpful?
Yes
No
-1
Wednesday, June 7th, 2017 AT 11:56 AM
Tiny
KEN
  • ADMIN
Hello,

It sounds like cleaning the MAF sensor helped but replacing it would fix it for good. Here is a guide hat will give you an idea of what you are in for when replacing the sensor:

https://www.2carpros.com/articles/how-to-replace-a-mass-air-flow-sensor-maf

Please let us know what happens.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Friday, June 9th, 2017 AT 8:27 PM
Tiny
KHURRAMNCP
  • MEMBER
  • 2006 TOYOTA YARIS
  • 1.3L
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 114,000 MILES
What could be the possible sources of engine vibrations when the car is in gear? The vibrations are not felt by sitting inside the car. The spark plugs (Denso Japan) are 20,000 Km old. Should I change them do they have any effect on the engine vibration. The car mileage is still very good.
Was this
answer
helpful?
Yes
No
Friday, June 9th, 2017 AT 8:27 PM (Merged)
Tiny
HMAC300
  • EXPERT
Vibrations can be cause d by a lot of things, belts out of line, motor mounts, etc. If your check engine light is on get it scanned for codes.
Was this
answer
helpful?
Yes
No
Friday, June 9th, 2017 AT 8:27 PM (Merged)
Tiny
KHURRAMNCP
  • MEMBER
  • 2006 TOYOTA YARIS
  • 1.3L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 112,000 MILES
The car engine vibrates when the gear is shifted to drive mode. In the neutral mode the engine stays calm. Throttle body has been also cleaned but the problem is still there.
Was this
answer
helpful?
Yes
No
+1
Friday, June 9th, 2017 AT 8:27 PM (Merged)
Tiny
HMAC300
  • EXPERT
Check for loose torque converter bolts and broken motor/transmission mount.
Was this
answer
helpful?
Yes
No
Friday, June 9th, 2017 AT 8:27 PM (Merged)

Please login or register to post a reply.

Recommended Guides