Suv not starting

Tiny
ECLARKE
  • MEMBER
  • TOYOTA
My Toyota 4ruuner suddently cuts off and will not start.I check the fuel pump and it is working ok. Icahnge the igniter module but it sill will not start. The engine is cranking ok but it just will not start.
Could you please help me in solving this problem.
Thank you very much
Clarke
Do you
have the same problem?
Yes
No
Wednesday, December 13th, 2006 AT 2:13 PM

5 Replies

Tiny
BACKYARDMECHANIC
  • MEMBER
You say you have fuel but what about spark. Do a spark check, if there is no spark then you have and ignition problem. If you have fuel and spark then I would say the timing is off and the chain/belt may have slipped. It would help to know the year, engine size, and mileage. Hope this is useful :)
Backyardmechanic
Was this
answer
helpful?
Yes
No
Wednesday, December 13th, 2006 AT 2:34 PM
Tiny
RASMATAZ
  • MEMBER
I check the fuel pump and it is working ok. Icahnge the igniter module but it sill will not start. The engine is cranking ok but it just will not start.

When you turn the key On, the pump will turn-on for 2 sec. It also comes On when cranking, thru the STA signal, do you have this. Items to check: Fuel pressure, EFI and circuit opening relay, fuel pump relay and EFI fuse.

You changed the ignitor-because you didn't get a spark. But where did you check for spark-at the coil or the s/p wire. If you have spark at the coil wire and nothing at the wire-inspect the cap and rotor it has to make it out of there. Note: the computer has to get an NE and G signal in order for it to sent an IGT sig to the ignitor telling it to turn-On once this is done the ignitor will confirm the IGF sig to the computer. Items to check: Ignition fuse-when this fuse blows it will not power the injectors thru circuit 10 and 20 to include the coil. HTH

Happy Holidays
Was this
answer
helpful?
Yes
No
Wednesday, December 13th, 2006 AT 3:47 PM
Tiny
ECLARKE
  • MEMBER
I change the distrbutor on the engine as well. The SUV is now starting however it will start for 30sec then it will shut off, because it keeps blowing the EFI fuse.
Can you please tell me what may be causing this.
Thank you very much
Earl
Was this
answer
helpful?
Yes
No
Friday, December 15th, 2006 AT 7:20 AM
Tiny
MATHIASO
  • MEMBER
The engine is cranking but won't start.
How it's happen?
When cranking, do the solenoid clicks or chatter?
What is the cranking voltage at the battery terminal posts?
Was this
answer
helpful?
Yes
No
Friday, December 15th, 2006 AT 8:01 AM
Tiny
BACKYARDMECHANIC
  • MEMBER
Dear Earl,
If the EFI fuse keeps blowning then you have one of two possibly problems. The EFI fuse should feed the fuel pump, which means there is a short in the fuel pump circuit or the pump itself is bad (electrically not mechanically). To find which it is exactly you can do the following. Do a short test on the car by disconnecting the postive cable and placing a 12v test lamp in series with the postive terminal of the battery. Make sure everything is off when preforming this test or you could get a false reading. If there is a short the test lamp will lite brightly. I am leaning toward the fuel pump being bad only because it takes awhile for the fuse to blow, which leads me to believe the pump is drawning more current as it continues to run untill the fuse gives out. Usually when there is a short somewhere in a circuit the fuse will blow right away.
Hope this helps Backyardmechanic :)
Was this
answer
helpful?
Yes
No
Friday, December 15th, 2006 AT 8:08 AM

Please login or register to post a reply.

Recommended Guides