1990 Toyota Corolla blinkers

Tiny
BRAAFLAT
  • MEMBER
  • 1990 TOYOTA COROLLA
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 148,000 MILES
I bought the car and the blinkers worked. I hooked up a stereo system and accidently made an ark when re-connecting the battery and now the blinkers dont work, and neither do the hazards. I checked the fuses and I tryed replacing the actual blinker itself on the steering column.
Do you
have the same problem?
Yes
No
Tuesday, July 29th, 2008 AT 8:04 PM

19 Replies

Tiny
KHLOW2008
  • EXPERT
Hi braaflat,

Did you check the turn signal relay? When installing the stereo, did you reconnect the hazard switch?
Was this
answer
helpful?
Yes
No
Friday, August 8th, 2008 AT 10:30 AM
Tiny
BRAAFLAT
  • MEMBER
Thanks for replying to my post. You were right about the hazards not being hooked up, so I hooked those up, and I checked the relay. Everything is good now, but the turnsignals still dont work. Any more suggestions?
Was this
answer
helpful?
Yes
No
Friday, August 8th, 2008 AT 8:16 PM
Tiny
KHLOW2008
  • EXPERT
Hi braaflat,

Check for a blown Turn signal fuse in underdash fuse box.
Was this
answer
helpful?
Yes
No
Saturday, August 9th, 2008 AT 5:49 AM
Tiny
BRAAFLAT
  • MEMBER
Hi, I checked the fuses, and there good too. I dont think I could have any open wires, I used a wire harness when hooking up the stereo.
Was this
answer
helpful?
Yes
No
Saturday, August 9th, 2008 AT 10:37 AM
Tiny
KHLOW2008
  • EXPERT
Are the hazard lights working?
Was this
answer
helpful?
Yes
No
Saturday, August 9th, 2008 AT 10:47 AM
Tiny
BRAAFLAT
  • MEMBER
No, nothing works
Was this
answer
helpful?
Yes
No
Saturday, August 9th, 2008 AT 11:57 AM
Tiny
KHLOW2008
  • EXPERT
Check the hazard/turn signal relay and its power supply and ground.
Was this
answer
helpful?
Yes
No
Saturday, August 9th, 2008 AT 3:35 PM
Tiny
BRAAFLAT
  • MEMBER
So there is a separate relay for the turnsignals and the hazards? When this problem first occurred, I replaced the relay for the hazards. Its still good because it clicks open when I press the hazards switch. If there are separate relays, where is the relay for the turnsignals?
Was this
answer
helpful?
Yes
No
Saturday, August 9th, 2008 AT 8:55 PM
Tiny
KHLOW2008
  • EXPERT
Hi braaflat,

No, they both share the same relay.

Lets start all over again.

With hazard switch turned on, does relay have clicking noise as if it is working? Or it clicks just once and then no more noise?
Was this
answer
helpful?
Yes
No
Sunday, August 10th, 2008 AT 2:51 AM
Tiny
BRAAFLAT
  • MEMBER
When I push the hazards switch, the relay clicks once.
Was this
answer
helpful?
Yes
No
Sunday, August 10th, 2008 AT 7:17 AM
Tiny
KHLOW2008
  • EXPERT
Did you test the relay? Replaced with a known good one?

Are the dash turn indicators showing when hazard switch is activated?
Was this
answer
helpful?
Yes
No
Sunday, August 10th, 2008 AT 10:17 AM
Tiny
BRAAFLAT
  • MEMBER
Im not sure how you test relays. I bought this relay new. The turn signals dont light up.
Was this
answer
helpful?
Yes
No
Sunday, August 10th, 2008 AT 12:31 PM
Tiny
KHLOW2008
  • EXPERT
Are the horns working? If not check the # 3 (15A) fuse in under hood fusebox.
Was this
answer
helpful?
Yes
No
Monday, August 11th, 2008 AT 8:20 AM
Tiny
BRAAFLAT
  • MEMBER
Yes the horns work.
Was this
answer
helpful?
Yes
No
Monday, August 11th, 2008 AT 3:52 PM
Tiny
KHLOW2008
  • EXPERT
It is not easy to describe the procedure for testing the circuit and I am unable to find any suitable wiring diagram.

Did you get the correct replacement part?
Was this
answer
helpful?
Yes
No
Tuesday, August 12th, 2008 AT 9:16 AM
Tiny
BRAAFLAT
  • MEMBER
Should be the right relay. The people at the parts store got it for me. Is the relay supposed to only click one time when I press the hazards? The relay doesnt make any noise when I activate turnsignals.
Was this
answer
helpful?
Yes
No
Tuesday, August 12th, 2008 AT 11:27 AM
Tiny
KHLOW2008
  • EXPERT
The relay is supposed to click at a regular interval when the switch is activated. Same when turn signal is activated.
Was this
answer
helpful?
Yes
No
Tuesday, August 12th, 2008 AT 11:30 AM
Tiny
BRAAFLAT
  • MEMBER
Just clicks once.
Was this
answer
helpful?
Yes
No
Tuesday, August 12th, 2008 AT 11:01 PM
Tiny
KHLOW2008
  • EXPERT
Hi braaflat,

Either the ground circuit is broken or the relay is faulty.

I suggest you check the relay again and if it does not help, you need to get the assistance of an auto electrician.
Was this
answer
helpful?
Yes
No
Wednesday, August 13th, 2008 AT 7:44 AM

Please login or register to post a reply.

Recommended Guides