2003 Toyota Camry No Heat

Tiny
SKIP11
  • MEMBER
  • 2003 TOYOTA CAMRY
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 125,000 MILES
Just noticed that the heater is not working.(At all)
1-A/C is fine
2-No apparent leaks
3-No smell of antifreeze
4-The thermostat gage is working fine
5-Antifreeze level is full when ice cold.
6-Fans and air direction controlls are fine
Do you
have the same problem?
Yes
No
Thursday, October 1st, 2009 AT 9:24 AM

4 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
With the engine hot and running and the heater on high, feel both heater core hoses. They should be hot.

Let me know what you find.
Was this
answer
helpful?
Yes
No
-2
Monday, October 5th, 2009 AT 7:26 AM
Tiny
SKIP11
  • MEMBER
Thanks for the reply. I actually found the problem this weekend. Both hoses were hot so I traced the problem to the blend door actuator. I took apart the actuator and cleaned the electodes. Works now, but I will need a new one soon. The electical tracks are worn out. Do you know if they sell a electrical conducting paint?
Was this
answer
helpful?
Yes
No
Monday, October 5th, 2009 AT 3:42 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If both hoses were hot, that was the next thing I planned to have you check. As far repairing it, I don't know of any such product, but that doesn't mean they don't make it. Maybe a good parts store would know.

Let me know what you find out and thanks for using 2carpros. Com.

Joe
Was this
answer
helpful?
Yes
No
Monday, October 5th, 2009 AT 8:27 PM
Tiny
HIFIGUY
  • MEMBER
Where is the blend door actuator, and is it easy to inspect?
Was this
answer
helpful?
Yes
No
+1
Monday, November 2nd, 2009 AT 2:31 AM

Please login or register to post a reply.

Recommended Guides