Theft deterent wont let my car start

Tiny
RENOR67
  • MEMBER
  • 2005 CADILLAC STS
  • V8
  • AUTOMATIC
  • 150,000 MILES
The theft system icon came on the dash while I was changing my battery out. The car acts like it want to start when I push to start the car but it just try to turn over like its going to start but it doesn't. It drained the battery so I went and bought a new battery for it and it drained that one as well. I've had the starter and the fuel pump checked and they both were fine. It sounds like its not getting any gas when it tries to start but it is getting gas just not turning over completely
Please help me
Do you
have the same problem?
Yes
No
Wednesday, May 6th, 2015 AT 9:55 AM

6 Replies

Tiny
SATURNTECH9
  • EXPERT
So with the key in the run position is the security light on solid or flashing? I need to know that first and if so was that why you ran your battery down from trying to start it with the security light on solid or flashing.
Was this
answer
helpful?
Yes
No
Wednesday, May 6th, 2015 AT 1:02 PM
Tiny
RENOR67
  • MEMBER
The security light comes on and goes off. When I push the push to start it tries for 10 seconds then it stops. The more I try it the slower it tries to turn over.
Was this
answer
helpful?
Yes
No
Wednesday, May 6th, 2015 AT 2:06 PM
Tiny
SATURNTECH9
  • EXPERT
If the security light turns off then I dont think the security system is keeping it from starting. Have you checked for codes yet?
Was this
answer
helpful?
Yes
No
Wednesday, May 6th, 2015 AT 10:28 PM
Tiny
RENOR67
  • MEMBER
There are no codes, I'm assuming since the car tries to start and don't completely turn over, the codes aren't registering.
Was this
answer
helpful?
Yes
No
Thursday, May 7th, 2015 AT 3:17 AM
Tiny
RENOR67
  • MEMBER
I had it checked and nothing shows up, Before this issue I had a code that was the 02 sensor, I had that replaced and the car only started once after that.
Was this
answer
helpful?
Yes
No
Thursday, May 7th, 2015 AT 3:20 AM
Tiny
SATURNTECH9
  • EXPERT
A code could have set from this new crank no start also if it was a security issue codes would be stored in the body control module. The diyer scan tools free code reads at the auto parts store cant read the body control module codes. Have you checked for spark? Also have you checked the actual fuel pressure? Also have you tried starting it on a prime from some carb spray?
Was this
answer
helpful?
Yes
No
Thursday, May 7th, 2015 AT 6:24 AM

Please login or register to post a reply.

Recommended Guides