Will not crank and economy mode activated

Tiny
VICKYBEE007
  • MEMBER
  • 2015 PEUGEOT 407
  • 2.5L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 40,000 MILES
The car does not crank at all. I checked the battery voltage and connector, everything was okay. I also checked the fuses on the PSF and the BSI, everything was okay too.
I have also checked the condition of the starter motor, it is working fine. I need your help please.
Saturday, April 28th, 2018 AT 8:16 AM

4 Replies

Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 44,369 POSTS
Hello,

Can I ask if the security light is flashing when you try to crank it over? If so please lock and unlock the car using the remote.

Please let us know.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Sunday, April 29th, 2018 AT 11:44 AM
Tiny
VICKYBEE007
  • MEMBER
  • 8 POSTS
Not at all sir. There was no security light flashing on the dashboard.
Was this
answer
helpful?
Yes
No
Sunday, April 29th, 2018 AT 12:19 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 44,369 POSTS
Does it seem like everything electrical is working but the engine is not turning over? (starter not working). There is a starter relay I would check here is a guide to help you.

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

I am not sure where the relay is because I do not have repair information. If you have the owners manual it will tell you where the relay is can you upload an image of its location it would be great.
Was this
answer
helpful?
Yes
No
Monday, April 30th, 2018 AT 11:10 AM
Tiny
VICKYBEE007
  • MEMBER
  • 8 POSTS
Okay then. I will do that tomorrow because I have closed for the day.
Was this
answer
helpful?
Yes
No
Monday, April 30th, 2018 AT 11:22 AM

Please login or register to post a reply.

Sponsored links