The car loses power when the heat or A/C is turned on

Tiny
DESHONGAR
  • MEMBER
  • 2004 CHEVROLET TRAILBLAZER
  • 4.2L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 181,000 MILES
So maybe a month ago the A/C was working fine then I stopped at the store and it just stop running, was no longer blowing cold but still ran.
When you hook a gauge to the high press for the Freon, it goes from empty (white) to over filled (red) to full (green).
Now when you get to turn the A/C or heat on you'll feel the engine vibrate while the engine quite down like it's losing power.
Do you
have the same problem?
Yes
No
Monday, October 21st, 2019 AT 7:41 AM

3 Replies

Tiny
KEN
  • ADMIN
Hello,

Did you added Freon? It sounds like the compressor has gone out? Can you please shoot a quick video with your phone so we can hear the noise? that would be great. You can upload it here with your response. Also is there is check engine light on if so lets run down this guide:

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
Tuesday, October 22nd, 2019 AT 4:11 PM
Tiny
DESHONGAR
  • MEMBER
I did the code reader, no codes came up.
The air compressor trips on and run fine, no skipping it lagging.
Yes, I added Freon but after watching the gauge it'll go to overcharged then go down on it's own.
And I will post a video.
Was this
answer
helpful?
Yes
No
Thursday, October 24th, 2019 AT 9:07 AM
Tiny
KEN
  • ADMIN
Please do a video this is a strange problem. So if the HVAC system is off the engine does not lose power?
Was this
answer
helpful?
Yes
No
Thursday, October 24th, 2019 AT 11:27 AM

Please login or register to post a reply.

Recommended Guides