Stereo displaying “a program cannot be read please consult a dealer” message

Tiny
JGONZO2398
  • MEMBER
  • 2010 MAZDA CX-9
  • 3.7L
  • V6
  • 2WD
  • AUTOMATIC
  • 160,000 MILES
I recently bought the vehicle listed above and I only have one pending issue with it. The stereo screen displaying a message saying the following “a program cannot be read please consult a dealer”. I have been looking on several forums and videos online, but they all are for different models or years, and I keep reading about this SD card slot you have to remove and reinsert to fix the issue. I cannot find that anywhere in this truck. Can I please get help here?
Tuesday, December 21st, 2021 AT 7:42 PM

13 Replies

Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,772 POSTS
Hi,

If there are no diagnostic trouble codes, then I would try to reset the unit. This will cause you to lose presets.

I looked through my schematics for the audio and there is nothing indicating an SD card.

Let me know if the reset works.

Take care,

Joe

See pics below.
Was this
answer
helpful?
Yes
No
Wednesday, December 22nd, 2021 AT 5:35 PM
Tiny
JGONZO2398
  • MEMBER
  • 349 POSTS
I don’t see a “folder switch” button.
Was this
answer
helpful?
Yes
No
+3
Wednesday, December 22nd, 2021 AT 5:45 PM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,772 POSTS
That looks slightly different than what my manual provided. Is there anything listed under the info or menu selections?

Joe
Was this
answer
helpful?
Yes
No
Wednesday, December 22nd, 2021 AT 9:14 PM
Tiny
JGONZO2398
  • MEMBER
  • 349 POSTS
None of those buttons have any function since the screen is stuck with that message. That is the issue.
Was this
answer
helpful?
Yes
No
Wednesday, December 22nd, 2021 AT 9:28 PM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,772 POSTS
Hi,

Is this a Bose system? Also, when you scanned for codes, did you use a scan tool that can read can-bus codes?

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Thursday, December 23rd, 2021 AT 9:10 PM
Tiny
JGONZO2398
  • MEMBER
  • 349 POSTS
I have a FIXD OBD scanner, but I have not scanned it for codes. I am not sure if that one can read those. Also, it does have the Bose audio system.
Was this
answer
helpful?
Yes
No
Thursday, December 23rd, 2021 AT 9:12 PM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,772 POSTS
That may be where I'm running into trouble. There could be codes related to the issue that we don't know about. I'm not familiar with the scanner you mentioned, so I'm of no help with that. Is there anything on it that indicates the word CAN?

Here is a link that explains how to scan the CAN system:

https://www.2carpros.com/articles/can-scan-controller-area-network-easy

If that is something your scan tool can't do, is there a place that would do it for you? It takes only a few minutes. If so, write down the codes and let me know what they are.

Take care. If I don't hear from you due to the holiday, I wish you and your family a Merry Christmas.

Joe
Was this
answer
helpful?
Yes
No
Thursday, December 23rd, 2021 AT 9:58 PM
Tiny
JGONZO2398
  • MEMBER
  • 349 POSTS
Problem fixed. Haha
Was this
answer
helpful?
Yes
No
Monday, December 27th, 2021 AT 7:17 PM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,772 POSTS
Hi,

Thanks for the update. I'm glad to hear you got it taken care of. What was the ultimate fix?

Joe
Was this
answer
helpful?
Yes
No
Monday, December 27th, 2021 AT 7:38 PM
Tiny
JGONZO2398
  • MEMBER
  • 349 POSTS
I just installed a new stereo. Did not feel like going through the trouble.
Was this
answer
helpful?
Yes
No
-1
Monday, December 27th, 2021 AT 7:51 PM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,772 POSTS
LOL. That will fix it. Regardless, I'm glad it's working again, and thanks for the update.

Please feel free to come back anytime in the future. You are always welcome here.

Take care and I wish you a Happy New Year!

Joe
Was this
answer
helpful?
Yes
No
Monday, December 27th, 2021 AT 8:12 PM
Tiny
JGONZO2398
  • MEMBER
  • 349 POSTS
Lol yes. I found a great deal on Crutchfield and a shop that offered a great price for installation so why not? And I do have an issue with a 2005 Toyota Camry LE that I would like to further diagnose. Loud clunking sounds when going over bumps but when I hop on the tires next to each strut and bounce the car up and down there is no noise.
Was this
answer
helpful?
Yes
No
Monday, December 27th, 2021 AT 8:16 PM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,772 POSTS
It sounds like the strut plate/mount at the top is bad. Not uncommon. Is it possible for you to start a new thread for this? We try to keep them specific to one topic so it's more helpful to others. I hope you understand.

Here is the link to start a new one. Just copy that above question and I'll get right on it.

https://www.2carpros.com/questions/new

Again, I hope you understand.

Take care and I'll watch for your new post.

Joe
Was this
answer
helpful?
Yes
No
Monday, December 27th, 2021 AT 8:27 PM

Please login or register to post a reply.

Related Radio Replace/Remove Content

Radio Head Unit Replacement
VIDEO

Sponsored links