Stability light keeps coming on

Tiny
LULL84
  • MEMBER
  • 2010 VAUXHALL ASTRA
  • 1.6L
  • 2WD
  • AUTOMATIC
  • 100,000 MILES
When driving in the snow it came up service stability trax and the stability light came on it then said reducing engine power I pulled over turned the car off then back on drove another 11 miles no problem. Then the next time I went out no snow but still abit icy it came on another 10 or so times each time I would stop turn the car off then back on again the all of a sudden it stopped and never came back on for the rest of the day. I went out in the car two days in a row and it never came on then on the third day it came on twice, then the next two days nothing then the next time I went out in it it done it once again.
Do you
have the same problem?
Yes
No
Wednesday, February 17th, 2021 AT 3:47 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

First, this vehicle isn't offered in the US. However, I'll try my best to help. As far as the issue, it sounds like it could be related to a bad wheel speed sensor or the connector. What I suggest is to check where they plug in. If the wiring and connectors all look good, then test the sensor itself.

Here is a link that explains how to test the sensors. You will need a multimeter to check the sensors.

https://www.2carpros.com/articles/abs-wheel-speed-sensor-test

If you find one is bad, here is a link that explains in general how one is replaced.

https://www.2carpros.com/articles/how-to-replace-an-abs-wheel-speed-sensor

I hope this helps. Let me know what you find or if you have other questions.

Take care and God Bless,

Joe
Was this
answer
helpful?
Yes
No
Wednesday, February 17th, 2021 AT 6:19 PM

Please login or register to post a reply.

Sponsored links